Opened 11 years ago

Closed 11 years ago

#5456 closed defect (fixed)

MediaMonitor not working under Qt4?

Reported by: Nigel Owned by: Nigel
Priority: minor Milestone: unknown
Component: mythvideo Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I'm not near a Linux machine ATM, but Mac OS X does:

2008-06-22 14:15:33.256 Starting MediaMonitor
2008-06-22 14:15:33.261 Found disk disk1 - volume name 'MythTV BurnDVD'.
2008-06-22 14:15:33.262 MonitorThreadDarwin::diskInsert(disk1,MythTV BurnDVD,1)
QObject: Cannot create children for a parent that is in a different thread.
(Parent is MediaMonitor(0x17d879b0), parent's thread is QThread(0x2407970), current thread is QThread(0x17d94ca0)
2008-06-22 14:15:33.263 Disk inserted on a supermount device
2008-06-22 14:15:33.263 Probable DVD detected.
2008-06-22 14:15:33.263 Detected MediaType MEDIATYPE_DVD
QObject::connect: Cannot queue arguments of type 'MediaStatus'
(Make sure 'MediaStatus' is registered using qRegisterMetaType().)

Change History (4)

comment:1 Changed 11 years ago by Rob Smith

Dupe of #5457?

comment:2 Changed 11 years ago by anonymous

Appears to be a problem on Linux, too:

QObject::connect: Cannot queue arguments of type 'MediaStatus'
(Make sure 'MediaStatus' is registered using qRegisterMetaType().)
2008-06-23 16:35:42.961 /dev/cdrom Disk OK, type = MEDIATYPE_DVD

comment:3 Changed 11 years ago by Nigel

(In [17608]) Re-enable plugin events after the Qt4 port. See #5456

comment:4 Changed 11 years ago by Nigel

Resolution: fixed
Status: newclosed

(In [17610]) Re-enable plugin events after the Qt4 port, and silence a runtime warning. The latter will probably also need fixing in mediamonitor-windows.cpp, but since Qt/4 builds are broken on MinGW, will have to wait. Closes #5456

Note: See TracTickets for help on using tickets.