Opened 11 years ago

Closed 11 years ago

#5486 closed patch (worksforme)

mythvideo cast order is backwards

Reported by: wstewart@… Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: mythvideo Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The cast order displayed by mythvideo is in reverse order instead of first billed order.

The attached patch corrects this for all new cast data fetched by the videomanager via imdb.pl. This was fixed is the last patch to #3585, unfortunately it did not make it into SVN, my apologies for not catching this earlier. For any movies that you have already fetched cast data for, unfortunately you would have to reset the metadata and re-fetch it from imdb. Or alternatively delete the cast data in the database and use the get_cast.py script attached to #3585 to re-fetch all the cast data.

Note that the cast order will be shown in reverse order after videomanager is used to fetch the data. You need to restart the frontend to fix this as some data is static in dbaccess.cpp. The problem is in the add function of MultiValueImp??, need to use push_front instead of push_back, but that function doesn't exist. Since this is minor, and is fixed by restarting the frontend I don't see a reason to fix it.

Note that this patch relies on the fact that the cast data is inserted into the database in first bill order, and that the database will return it this way.

Refs #3585

Attachments (2)

mythvideo-cast.diff (1.2 KB) - added by wstewart@… 11 years ago.
mythvideo-cast.2.diff (1.2 KB) - added by wstewart@… 11 years ago.
Updated for trunk

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by wstewart@…

Attachment: mythvideo-cast.diff added

comment:1 Changed 11 years ago by wstewart@…

Oh I forgot, one other thing the patch does is remove "None defined" for the cast. If no cast is defined (ie. none at imdb), then "None defined" is shown when browsing videos. I prefer nothing to be shown.

comment:2 Changed 11 years ago by Dibblah

Status: newassigned

Changed 11 years ago by wstewart@…

Attachment: mythvideo-cast.2.diff added

Updated for trunk

comment:3 Changed 11 years ago by wstewart@…

Patch has been updated for trunk

comment:4 Changed 11 years ago by wstewart@…

pretty sure this is no longer needed with trunk. Will confirm on my next upgrade to SVN which should be within the next week.

comment:5 Changed 11 years ago by Anduin Withers

Resolution: worksforme
Status: assignedclosed

There is almost no way for this to order properly over time, if it still isn't good enough we'll add an explicit order field to the DB.

Note: See TracTickets for help on using tickets.