Opened 14 years ago

Closed 13 years ago

#549 closed patch (invalid)

make 3/9 act as pageup/down in three places that need it

Reported by: gnassas@… Owned by: cpinkham
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

There are probably more than three places that could use this but I added it to three dialogs that frequently vex me: 1) the category search in schedule recordings; 2) the list of videos in mythvideo setup 3) the list of thumbnails in mythvideo setup.

Since 1) is an update to MythListBox? there are other dialogs which are affected but I don't believe any of them carry as long a list as category search.

Attachments (2)

pgupdown.mythtv.diff.gz (455 bytes) - added by gnassas@… 14 years ago.
changes to mythtv source
pgupdown.mythvideo.diff.gz (257 bytes) - added by gnassas@… 14 years ago.
changes to mythvideo source

Download all attachments as: .zip

Change History (9)

Changed 14 years ago by gnassas@…

Attachment: pgupdown.mythtv.diff.gz added

changes to mythtv source

Changed 14 years ago by gnassas@…

Attachment: pgupdown.mythvideo.diff.gz added

changes to mythvideo source

comment:1 Changed 14 years ago by anonymous

Type: enhancementpatch

comment:2 Changed 14 years ago by cpinkham

What's wrong with mapping PageUp/PageDown? on your remote? I think you could also do this in mythcontrols by binding your '3' and '9' keys to PageUp/PageDown? for the 'qt' context since that context applies to these widgets.

comment:3 Changed 14 years ago by gnassas@…

What's wrong with mapping PageUp/PageDown?? on your remote?

I've never seen a remote with PageUp/Down?. Certainly none of mine do and the existing buttons are already mapped.

you could also do this in mythcontrols

< Johnny Carson SNL voice > I did not know that. </>

If it's true then the ticket might be inverted to remove the 3/9 mapping from the places that already do it. I'll have to poke around.

  • George

comment:4 Changed 14 years ago by cpinkham

Owner: changed from gnassas@… to cpinkham

I think the issue is that '3' is mapped to PAGEUP in the "TV Playback" context, but the actual PgUp? key is mapped to PAGEUP Globally. Even if PageUp/PageDown? are not on a remote, a lot of people map something to PageUp/PageDown? because these keys are used in quite a few places. I map the keys on each side of my "0" key so one side is PgUp? and the other PgDown?. I'll have another look at this as well.

comment:5 Changed 13 years ago by gnassas@…

This ticket has been moribund for a while but a few weeks ago I did follow up on this suggestion:

you could also do this in mythcontrols

without success. The idea was to add a 3/9 mapping to the Qt context to achieve the same behaviour. I tried that with two sql inserts but couldn't get 3/9 to act as pageup/down.

Is it possible that the global context comes before the Qt one? If so then this change needs to be done through code. I'm out of the country for a week and can't test that until next week.

  • George

comment:6 Changed 13 years ago by cpinkham

Milestone: 0.190.20

I really think we should be going the opposite direction with this patch, not adding more places where 3/9 act as pageup/down. If people want 3/9 to act as page up/down on a screen, then they should setup they keybindings appropriately. If keybindings don't exist in that area then maybe they should. I'm going to move this to a 0.20 milestone since as George stated it may require code changes and we're frozen for 0.19.

comment:7 Changed 13 years ago by gnassas@…

Resolution: invalid
Status: newclosed

Revisted this and noticed that I had tested using "Qt" as a context which is wrong. The correct name is "qt". If you add 3 and 9 there you get the desired behaviour.

So, this ticket is withdrawn.

Note: See TracTickets for help on using tickets.