Opened 11 years ago

Closed 11 years ago

#5497 closed patch (fixed)

mythudprelay (callerid.xsl) formats numbers improperly

Reported by: michael bishop <clever@…> Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: contrib Version: head
Severity: medium Keywords: easy
Cc: Ticket locked: no

Description

my phone provider/modem returns local phone numbers as 7 digits(no area code) which causes the 1112222 to get formated as (111) 222-2

this patch to callerid.xsl fixes it for Canada(and probably usa too)

may also help to keep separate xsl files for each country.

Attachments (1)

5497_callerid.xsl.patch (1.0 KB) - added by michael bishop <clever@…> 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by michael bishop <clever@…>

Attachment: 5497_callerid.xsl.patch added

comment:1 Changed 11 years ago by laga

Keywords: easy added

This looks like an easy fix. According to Michael Bishop, the current format is already wrong for several countries, so the risk for regressions is probably low:

< clev> laga: i dont know how it will react for other countrys, but the existing xls file expects a phone# to be (123)-456-7890, which is allready wrong for several countrys
< clev> laga: so technicaly its allready broken for any country that doesnt use that format for phone#

comment:2 Changed 11 years ago by Rob Smith

Owner: changed from Isaac Richards to Rob Smith
Status: newaccepted

comment:3 Changed 11 years ago by Rob Smith

Resolution: fixed
Status: acceptedclosed

(In [20394]) Fixes #5497, this formats 7 digit phone numbers correctly for mythudprelay

Note: See TracTickets for help on using tickets.