Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#555 closed defect (wontfix)

SVN does not record shows with the Record button

Reported by: dag@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Watching liveTV and pressing the Record button will not do any actual recording.

For some reason a also have to press the Record button twice(?) to get any reaction.

The show will be partly marked as being recorded, but no file will be put onto disk and nothing appears in the "recorded shows" window. The backend status will be "recording" until the show ends and it seems to be impossible to get it out of that state without restarting it.

Timed recordings seems to work fine, even if I did have a issue with the timed recording that was overlapping one of the phantom recordings mentioned earlier. Even if the phantom stopped the scheduled one didn't start after that. This might of course be the intended behavior for overlapping recordings, but I would rather have half a show than no show at all...

I have only one tuner at the moment, could there be a scheduling conflict here somewhere?

Attachments (1)

mythtv.log (19.6 KB) - added by anonymous 14 years ago.

Download all attachments as: .zip

Change History (3)

Changed 14 years ago by anonymous

Attachment: mythtv.log added

comment:1 Changed 14 years ago by anonymous

Resolution: wontfix
Status: newclosed

It looks like the recording start up correctly but is shut down almost immediately when the fronend playback stops. The frontend tells the backend to stop using the RingBuffer? which it is using to write the recording to disk...

This is a bug, but I'm not going to fix it now since code resposible for this will be removed by #340.

The workaround is to not start recordings in LiveTV when you don't have another tuner to make the recording.

comment:2 Changed 14 years ago by dag@…

Fair enough, as long as I know it is not me ;-)

Hope that #340 will be done soon...

Note: See TracTickets for help on using tickets.