Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#556 closed defect (fixed)

OSD illegible in SVN 7664

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I've built 7664 and OSD is now broken. I've seen many recent commits referencing OSD. I use XV, but not XVMC. OSD works (b&w) with XVMC. When I use standard/ffmpeg, the OSD is completely illegible. Lacking better words to describe the issue, it looks like the horizontal hold (from an old TV) is broken for the OSD layer. When I enter a new channel, instead of green numbers in the upper right, I have a few lines of white dots all across the top of my screen. There are similar effects from opening the menu or info OSD.

Change History (4)

comment:1 Changed 14 years ago by anonymous

Milestone: unknown
Owner: changed from Isaac Richards to danielk
Version: head

This works for me...

What letterboxing mode are you using?

What OSD Theme are you using?

Have you tried a other OSD Themes?

What are the resolutions and aspect ratios of the video and MythTV window when you see this?

comment:2 Changed 14 years ago by bjm <bjm@…>

The scrambled "horizontal hold" OSD happens when the VertScanPercentage?, HorizScanPercentage? are not set to zero. Please fix this regression.

comment:3 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: newclosed

(In [7667]) Use the video width, not the display width for the osd initialization.

Fixes #556 for me.

comment:4 Changed 14 years ago by anonymous

Fixed #556 for me, too.

Note: See TracTickets for help on using tickets.