Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5573 closed defect (fixed)

Problems with multiple players for the same system

Reported by: John <jrlagrone@…> Owned by: greg
Priority: minor Milestone: unknown
Component: mythgame Version: 0.21-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

When multiple players are used for the same system (say snes9x and zsnes for SNES) the "players available please pick one" dialog is produced, but list no players to choose from. When looking at the rom info they also list no players. However, if just one player is set up everything runs fine.

Change History (4)

comment:1 in reply to:  description ; Changed 11 years ago by anonymous

The problem described sounds like it would be coming from the block of code in mythgame/rominfo.cpp. I'm not all that familiar with querying techniques used or how may have been modified within myth; but judging from the rest of the file, I believe the problem is the actual query call.

I Believe

275	        query.exec(thequery);

Should simply be

275	        query.exec();

comment:2 in reply to:  1 Changed 11 years ago by john <jrlagrone@…>

Replying to anonymous:

The problem described sounds like it would be coming from the block of code in mythgame/rominfo.cpp. I'm not all that familiar with querying techniques used or how may have been modified within myth; but judging from the rest of the file, I believe the problem is the actual query call.

I Believe

275	        query.exec(thequery);

Should simply be

275	        query.exec();

I can confirm that this change fixes my problem. I'd also like to note that this also appears in the trunk version.

comment:3 Changed 11 years ago by Nigel

Resolution: fixed
Status: newclosed

(In [17964]) Fix a broken query (and bad whitespace). Closes #5573.

comment:4 Changed 11 years ago by Nigel

(In [17965]) Oops, forgot to apply to fixes. Fix a broken query (and bad whitespace). Closes #5573.

Note: See TracTickets for help on using tickets.