Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5598 closed defect (duplicate)

No audio with ac3 "mono" tracks

Reported by: tafypz Owned by: Isaac Richards
Priority: minor Milestone: 0.21.1
Component: Video Playback Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When I try to play a DVD with audio tracks in mono, I don't get any sound. the latest Mplayer from atrpms and the latest VLC have no problem playing it with audio.

here is the log I get with mythfrontend -v playback :

libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00000144 libdvdread: Elapsed time 0 libdvdread: Found 1 VTS's libdvdread: Elapsed time 0 2008-08-01 20:18:16.862 AFD: Opened codec 0x251b5d0, id(MPEG2VIDEO) type(Video) 2008-08-01 20:18:16.862 NVP: Disabling Audio, params(-1,-1,-1) 2008-08-01 20:18:16.887 VideoOutputXv?: XVideo Adaptor Name: 'NV17 Video Texture' 2008-08-01 20:18:16.893 DPMS Deactivated 2008-08-01 20:18:16.919 OSD Theme Dimensions W: 640 H: 480 2008-08-01 20:18:17.486 TV: Changing from None to WatchingPreRecorded? QSettings::sync: filename is null/empty 2008-08-01 20:18:17.488 New DB connection, total: 3 2008-08-01 20:18:17.502 Connected to database 'mythconverg' at host: 192.168.0.21 2008-08-01 20:18:17.612 OpenGLVideoSync() 2008-08-01 20:18:17.652 Video timing method: SGI OpenGL 2008-08-01 20:18:18.028 AFD: Warning, video codec 0x251b5d0 id(MPEG2VIDEO) type (Video) already open. 2008-08-01 20:18:18.303 AFD: codec AC3 has 0 channels No accelerated IMDCT transform found 2008-08-01 20:18:18.304 AFD: Opened codec 0x4353be0, id(AC3) type(Audio) 2008-08-01 20:18:18.307 Opening audio device 'default'. ch 1(1) sr 48000 2008-08-01 20:18:18.307 Opening ALSA audio device 'default'. 2008-08-01 20:18:18.309 AudioOutput? Error: Channels count (1) not available: Invalid argument 2008-08-01 20:18:18.309 AudioOutput? Error: Unable to set ALSA parameters 2008-08-01 20:18:18.309 NVP: Disabling Audio, reason is: Unable to set ALSA parameters 2008-08-01 20:18:18.312 AFD: Warning, video codec 0x251b5d0 id(MPEG2VIDEO) type (Video) already open. 2008-08-01 20:18:18.314 AFD: Warning, audio codec 0x4353be0 id(AC3) type (Audio) already open, leaving it alone. 2008-08-01 20:18:18.314 AFD: codec AC3 has 1 channels 2008-08-01 20:18:18.314 AFD: codec AC3 has 0 channels No accelerated IMDCT transform found 2008-08-01 20:18:18.315 AFD: Opened codec 0x2965570, id(AC3) type(Audio) 2008-08-01 20:18:18.315 NVP: Disabling Audio, params(0,-1,-1) 2008-08-01 20:18:18.317 Opening audio device 'default'. ch 1(1) sr 48000 2008-08-01 20:18:18.317 Opening ALSA audio device 'default'. 2008-08-01 20:18:18.317 AudioOutput? Error: Channels count (1) not available: Invalid argument 2008-08-01 20:18:18.317 AudioOutput? Error: Unable to set ALSA parameters 2008-08-01 20:18:18.317 NVP: Disabling Audio, reason is: Unable to set ALSA parameters 2008-08-01 20:18:18.321 AFD: Warning, video codec 0x251b5d0 id(MPEG2VIDEO) type (Video) already open. 2008-08-01 20:18:18.321 AFD: Warning, audio codec 0x4353be0 id(AC3) type (Audio) already open, leaving it alone. 2008-08-01 20:18:18.321 AFD: codec AC3 has 1 channels 2008-08-01 20:18:18.321 AFD: Warning, audio codec 0x2965570 id(AC3) type (Audio) already open, leaving it alone. 2008-08-01 20:18:18.321 AFD: codec AC3 has 1 channels 2008-08-01 20:18:18.321 AFD: codec AC3 has 0 channels No accelerated IMDCT transform found 2008-08-01 20:18:18.321 AFD: Opened codec 0x43a6bd0, id(AC3) type(Audio) 2008-08-01 20:18:18.322 NVP: Disabling Audio, params(0,-1,-1) 2008-08-01 20:18:18.322 Opening audio device 'default'. ch 1(1) sr 48000 2008-08-01 20:18:18.322 Opening ALSA audio device 'default'. 2008-08-01 20:18:18.322 AudioOutput? Error: Channels count (1) not available: Invalid argument 2008-08-01 20:18:18.323 AudioOutput? Error: Unable to set ALSA parameters 2008-08-01 20:18:18.323 NVP: Disabling Audio, reason is: Unable to set ALSA parameters

Attachments (1)

log.txt (3.6 KB) - added by tafypz 11 years ago.
Log

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by tafypz

Attachment: log.txt added

Log

comment:1 Changed 11 years ago by stuartm

Component: mythtvVideo Playback

comment:2 Changed 11 years ago by dekarl@…

Maybe this got fixed together with #3825 (no audio on mono DVB) At least the error message is the same: AudioOutput?? Error: Channels count (1) not available: Invalid argument

comment:3 Changed 11 years ago by Dibblah

Resolution: duplicate
Status: newclosed

Should be fixed when #5900 is committed

comment:4 Changed 11 years ago by andy@…

I found a similar problem with digital TV recordings from a couple channels. One with the problem is the digital KRCB broadcast on San Francisco Comcast 107-1. The audio in the recording is (according to mplayer) "AC3: 1.0 (mono) 48000 Hz 192.0 kbit/s". mplayer clones the mono recording internally and it plays with sound. mythtv reports the "Channels count (1) not available" error.

I tried the patch from #5900 (applied to trunk r20297), but it did not resolve the problem.

However, I was able to resolve the problem by setting up asound.conf to have ALSA do the cloning (the hw:0,3 specification is needed in my system for HDMI out, should probably be hw:0,0 in most cases).

I am just doing stereo output, not 5.1.

pcm_slave.2ch {
  pcm "hw:0,3"
  channels 2
}

pcm.!default {
  type plug
  slave 2ch
}
Note: See TracTickets for help on using tickets.