Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#5616 closed Bug Report - General (fixed)

mythtv-setup XMLTVFindGrabbers -- Cannot create children for a parent that is in a different thread

Reported by: sphery <mtdean@…> Owned by: Anduin Withers
Priority: minor Milestone: 0.24
Component: mythtv Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

In mythtv-setup when entering Video Sources and selecting a video source (in my case a Schedules Direct source), the errors:

QObject: Cannot create children for a parent that is in a different thread.
(Parent is QProcess(0x8bd50ec), parent's thread is QThread(0x87d3cc8), current thread is XMLTVFindGrabbers(0x8bd50e4)
QObject: Cannot create children for a parent that is in a different thread.
(Parent is QProcess(0x8bd50ec), parent's thread is QThread(0x87d3cc8), current thread is XMLTVFindGrabbers(0x8bd50e4)
QObject: Cannot create children for a parent that is in a different thread.
(Parent is QProcess(0x8bd50ec), parent's thread is QThread(0x87d3cc8), current thread is XMLTVFindGrabbers(0x8bd50e4)
QObject: Cannot create children for a parent that is in a different thread.
(Parent is QProcess(0x8bd50ec), parent's thread is QThread(0x87d3cc8), current thread is XMLTVFindGrabbers(0x8bd50e4)
QObject: Cannot create children for a parent that is in a different thread.
(Parent is QProcess(0x8bd50ec), parent's thread is QThread(0x87d3cc8), current thread is XMLTVFindGrabbers(0x8bd50e4)
2008-08-12 18:24:13.268 XMLTVFindGrabbers: Failed to run tv_find_grabbers
2008-08-12 18:24:14.385 Fetching lineups from Schedules Direct...

occur and then mythtv-setup seems to lock up. BT attached for good measure.

Attachments (1)

gdb-5616.txt (44.5 KB) - added by sphery <mtdean@…> 11 years ago.
backtrack created by Ctrl-C'ing mythtv setup when it locked up

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by sphery <mtdean@…>

Attachment: gdb-5616.txt added

backtrack created by Ctrl-C'ing mythtv setup when it locked up

comment:1 Changed 11 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newassigned

I'll check this out in the next few days if no one else gets to it first.

PS I get the error messages, but not the lockup.

comment:2 Changed 11 years ago by anonymous

try inhering ur class from QBoject publicly, like:

class Myclass: public QObject, public <whatever other class it's inheriting from> {

Q_OBJECT;

}

comment:3 Changed 11 years ago by newbury@…

2 things: 1) Given the age of this trac ticket, I suspect the problem is specific to mythtv-setup. I upgraded my home machine *but did not run mythtv-setup* and have had no problems with BE or FE. 2) I wonder if perhaps this might be triggered in some way by the non-existence of tuner hardware. I updated my office (test)setup to 18425 yesterday, but I have no tuners in the box. Mythtv-setup did not like that...then it failed when attempting to download lineups. This attempted setup is using a copy of the home machine mythconverg database (which of course, has tuners in it).

comment:4 Changed 11 years ago by Anduin Withers

Owner: changed from danielk to Anduin Withers

comment:5 Changed 11 years ago by Anduin Withers

Resolution: fixed
Status: assignedclosed

(In [18447]) Closes #5616

  • Fixes QProcess parent thread issue.
  • Fixes deadlock (probably seen most often by people without XMLTV installed or when editing/adding a source more than once).

comment:6 Changed 11 years ago by Anduin Withers

(In [18806]) References #5616

Fix a bug I didn't actually fix in [18447].

  • Fixes QProcess parent thread issue.

My last attempt didn't actually fix the "parent in a different thread" issue and didn't fix the "QProcess is thread-safe" assumption.

comment:7 Changed 8 years ago by managementboy@…

I am not sure if I should open a new ticket for this (3 years old), I apologize in advance. Same problem with trunk v0.25-rc-111-gc7a1e81 when opening the metadata setup screen. No way to get out of the screen after selecting it. Could it be that it has something to do that I do not have mythgame installed?

2012-04-01 14:28:59.583349 N  Found mainmenu.xml for theme 'Willi'
2012-04-01 14:28:59.851644 I  MythCoreContext: Connecting to backend server: 127.0.0.1:6543 (try 1 of 1)
2012-04-01 14:28:59.852990 I  Using protocol version 72
2012-04-01 14:28:59.863836 I  Bonjour: Service registration complete: name 'Mythfrontend on elkin' type '_mythfrontend._tcp.' domain: 'local.'
QObject: Cannot create children for a parent that is in a different thread.
(Parent is MythScreenStack(0xbc0b70), parent's thread is QThread(0xa82ac0), current thread is QThread(0x7f2a155f16c0)
2012-04-01 14:29:05.148643 I  Received remote 'Clear Cache' request
MythTV Version : v0.25-rc-111-gc7a1e81
MythTV Branch : master
Network Protocol : 72
Library API : 0.25.20120315-2
QT Version : 4.7.4
Options compiled in:
 linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live using_mheg using_libass using_libxml2

comment:8 Changed 8 years ago by stuartm

Milestone: unknown0.24
Ticket locked: set
Type: defectBug Report - General
Version: headMaster Head

Please open a new ticket

Note: See TracTickets for help on using tickets.