Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#5622 closed enhancement (fixed)

Add vertical strech fill mode

Reported by: mythdev@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords: letterbox, fill
Cc: Ticket locked: no

Description

In the Netherlands, the analog broadcasters have a lot of shows that are in the letterbox format.

That means there are 2 black bars in the signal, so my PVR-150 records the video with the 2 bars in it, which is the expected behavior. Playing back these videos on a MythFrontend results in the black bars being displayed as well, as is expected, since the bars are in the video.

This patch adds a new fill method "Vertical Stretch" which removes the black bars from the visible area.

Also this patch fixes a bug with the VideoOutput::ToggleAdjustFill?, as kAspect_END was used and it should be kAdjustFill_END.

In the past there has been a lot of discussion on whether or not to add this fill mode, but I see no other way to accomplish this. Please see the attached screenshots for the differences between the fill modes.

My FE is set to 16:9 aspect ratio. Also the MPEG2 file has the 16:9 aspect ratio, but the black bars are recorded into the MPEG2 file, because that is the way a lot of shows are broadcasted here (analog).

Attachments (4)

Vertical_Strech_Fill_mode.patch (2.2 KB) - added by mythdev@… 11 years ago.
The patch that adds a vertical stretch fill mode and fixes the kAspect_END bug
Full_fill.png (194.8 KB) - added by mythdev@… 11 years ago.
This is how the content looks with the "full" fill mode (notice the logo is out of the displayable area)
No_fill.png (176.2 KB) - added by mythdev@… 11 years ago.
Original content, without a fill mode
VStretch.png (188.8 KB) - added by mythdev@… 11 years ago.
Content when the fill mode is Vertical Stretched (Notice all content is in the viewable area now)

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by mythdev@…

The patch that adds a vertical stretch fill mode and fixes the kAspect_END bug

Changed 11 years ago by mythdev@…

Attachment: Full_fill.png added

This is how the content looks with the "full" fill mode (notice the logo is out of the displayable area)

Changed 11 years ago by mythdev@…

Attachment: No_fill.png added

Original content, without a fill mode

Changed 11 years ago by mythdev@…

Attachment: VStretch.png added

Content when the fill mode is Vertical Stretched (Notice all content is in the viewable area now)

comment:1 Changed 11 years ago by Dibblah

Please look at #4872 for an alternative solution

comment:2 Changed 11 years ago by mythdev@…

This fill mode can be used together with the patch from #4872, but still, the "half" and "full" fill modes are not really suitable to be used in the case I described.

comment:3 Changed 11 years ago by Robin Gilks <g8ecj@…>

Works great for the use case of capture from an STB where the provider can't make up their minds just which way (letter or pillar box) they are going to broadcast where the PVR150 is capturing in 16:9. Having the one extra (symmetric) choice allows for all instances.

Applied cleanly with fuzz to 0.21-fixes r18091.

comment:4 Changed 11 years ago by mythdev@…

Is there any change this patch will make it into mythtv? And if not, why not.

I do not want to sound impatient or ungrateful, because I really love mythtv, but I am just interested in why this ticket does not get any reaction from one of the "core" developers. Is it the way I made the patch or the ticket? Or is this feature not wanted?

Thank you for understanding and please do not feel offended.

comment:5 in reply to:  4 Changed 11 years ago by anonymous

Replying to mythdev@telfort.nl:

Is there any change this patch will make it into mythtv? And if not, why not.

I do not want to sound impatient or ungrateful, because I really love mythtv, but I am just interested in why this ticket does not get any reaction from one of the "core" developers. Is it the way I made the patch or the ticket? Or is this feature not wanted?

Thank you for understanding and please do not feel offended.

The same reason #4872 isn't in yet, or the same reason why it took #1104 almost 2 years to get included, because the developers have other priorities and huge backlog of tickets. Unfortunately, sometimes good (and bad) patches sit a LONG time in trac. Wish it wasn't the case, but complaining probably won't help... if it's still not in within the next 8 months, then ask again.

comment:6 Changed 10 years ago by danielk

Resolution: wontfix
Status: newclosed

All additional stretch modes should be user defined by saving and naming a manual zoom.

comment:7 Changed 10 years ago by danielk

Resolution: wontfixfixed

(In [20406]) Fixes #5622. Adds a vertical stretch mode.

Note: This breaks the 'no new general zoom modes' rule, but Robin Gilks made a valid argument that stretch modes can not be implemented as saved manual zooms.

Note: See TracTickets for help on using tickets.