Opened 11 years ago

Closed 11 years ago

#5631 closed defect (fixed)

Loss of keyboard control after mythbrowser setup

Reported by: eric.bosch@… Owned by: paulh
Priority: minor Milestone: 0.22
Component: mythbrowser Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I am currently running latest SVN (18160), and after enterring mythbrowser setup screen and adding new bookmark, the browser configuration appears successful, but after exiting the setup screen, mythfrontend no longer responds to keyboard or remote control. CPU usage remains normal, and nothing appears on logs. Only way to recover is to kill mythfrontend and restart. Mythbrowser works fine after this.

Change History (3)

comment:1 Changed 11 years ago by eric.bosch@…

If you need any kind of trace or other debug info, let me know, and I'll be happy to provide, just let me know how!

comment:2 Changed 11 years ago by paulh

Owner: changed from Isaac Richards to paulh
Status: newassigned

This will be fixed when the bookmark manager and settings screen are converted over to MythUI.

comment:3 Changed 11 years ago by paulh

Resolution: fixed
Status: assignedclosed

(In [18196]) MythBrowser? updates.

  • Add option to add/edit/view bookmarks from within MythBrowser?.
  • Add some database schema update code to make it easier to update in the future. Note due to some DB changes you will lose any existing bookmarks.

NOTE: The bookmark manager uses MythUIButtonList in many places which triggers the MythImage? inheritance bug. Greg and Stuart M are both working on a new image cache which will hopefully fix this but until then expect some strange behaviour with some of the lists and menus.

Note: See TracTickets for help on using tickets.