Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5637 closed defect (fixed)

Mythtv cannot play recordings from KQED made with HDHR

Reported by: allen dot edwards at oldpaloalto dot com Owned by: danielk
Priority: minor Milestone: 0.22
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This had been verified with 4 other users and 2 systems at my site. There is apparently a header issue with KQED that HDHR processes in such a way that it locks up mythfrontend when you try and play it back. The file can be played with mplayer and KQED can be recorded and played with an air2pc. All other channels are fine. I think the first errors in mythfrontend.log are: 2008-08-22 14:18:45.003 Tuning to 'MPEG Program 1' pnum: 0x1 without CRC check on PMT 2008-08-22 14:18:45.008 mpegts_read_header: could not find any PMT's

Lots of errors follow. Nothing unusual in mythbackend.log or the the mysql log.

I spent all day yesterday figuring this out after many days of trying things. I built up a second system just to eliminate the possibility it was my system. It is 100% repeatable.

It should be noted that this applies to 9.1 and 9.2 while 9.3 is fine. 9.2 is a rebroadcast of KTEH.

Allen

Change History (12)

comment:1 Changed 11 years ago by anonymous

Also note that once you watch one of these shows, you have to restart mythfrontend to get anything to play. Nothing will play once one of these shows has been even previewed.

Allen

comment:2 Changed 11 years ago by ylee@…

I'm one of the other users that helped confirm that this bug isn't just on Allen's setup. Let me add to his comments:

  • Allen figures that the change on KQED's part that triggered the issue with mythfrontend and the HDHomeRun occurred on or around 15 August. I can't confirm that precisely, but the last good KQED recording I have is from 12 August and the issue suddenly appeared toward the end of that week, so the 15th sounds about right.
  • Both the latest HDHomeRun firmware (20080823) and the previous one (20080427) exhibit this behavior.
  • When played back, the affected KQED recordings have grey video with static.
  • As Allen notes, even attempting to preview one of the affected recordings (resulting in no preview) causes mythfrontend to display *all* recordings, regardless of source, as grey video with static. Restarting mythfrontend is required.
  • A full rescan of OTA channels did not help with the issue.

comment:3 Changed 11 years ago by jafa@…

Hi,

We have reproduced the problem. The HDHomeRun is working correctly... mythtv is getting confused.

The only interesting quirk with KQED is that the PMT is larger than 188 bytes and as such is fragmented across two transport frames. The PMT is well formed and works with the HDHomeRun software, TSreader, and DVBSnoop. The CRC is valid.

Nick - Silicondust (HDHomeRun)

comment:4 Changed 11 years ago by matt@…

This has now occurred for me with KYW in Philadelphia as well.

comment:5 Changed 11 years ago by ylee@…

Given Matt's report, I should point him and others interested to the workaround for the issue. Note that this is indeed a workaround; the underlying bug within the mythfrontend code still exists.

comment:6 Changed 11 years ago by stuartm

Milestone: unknown0.22

comment:7 Changed 11 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newaccepted

comment:8 Changed 11 years ago by danielk

I believe the problem is that

  void HDHRRecorder::HandleSingleProgramPMT(ProgramMapTable *pmt)

assumes the single program PMT fits in one TS packet, so it only writes the first 184 bytes of the PMT.

comment:9 Changed 11 years ago by danielk

Resolution: fixed
Status: acceptedclosed

(In [19646]) Fixes #5637. Allow HDHomeRun to handle PMT's larger than 184 bytes.

comment:10 Changed 11 years ago by ylee@…

The patch applies cleanly to 0.21-fixes and, in a quick test on KQEDDT, appears to solve the problem. (Not that the workaround was ever a problem, but nice to know that a MythTV bug is fixed.)

comment:11 Changed 11 years ago by skamithi

(In [19700]) Refs #5637. commit [19646] to 0.21 fixes

comment:12 in reply to:  2 Changed 11 years ago by ylee@…

Is it not premature to close the ticket? The PMT issue has been fixed, but the underlying fault in the video-output code that the issue exposed, requiring a restart of mythfrontend, hasn't.

Note: See TracTickets for help on using tickets.