Opened 14 years ago

Closed 14 years ago

#564 closed defect (fixed)

Editing cutlist, seek to next keyframe doesn't work for HDTV

Reported by: jppoet@… Owned by: danielk
Priority: trivial Milestone: 0.19
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description (last modified by danielk)

When editing a cutlist, seeking to the previous KEYFRAME works, but attempting to move to the next KEYFRAME just results in moving to the next FRAME.

This bug only affects recordings made with my HD-3000 card (using DVB drivers). Seeking to the next keyframe works correctly on recording made with my PVR-500.

Change History (3)

comment:1 Changed 14 years ago by Stuart Auchterlonie

Milestone: 0.19
Priority: minortrivial
Version: head

I see this as well on my DVB recordings. So it's probably DVB specific

comment:2 Changed 14 years ago by danielk

Description: modified (diff)
Owner: changed from Isaac Richards to danielk

comment:3 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [7743]) Fixes #564.

The problem is really that keyframe distance detection is disabled when we use MARK_GOP_BYFRAME, but fixing that is somewhat involved. Until I get to that, this two liner should do just fine. It uses a keyframe distance of 18 for jumping forward by a keyframe when the keyframedist looks suspect. This should work for any keyframe distance over 9 and less than 19, i.e. the common MPEG-2 distances of 12,15,18 are all covered.

Note: See TracTickets for help on using tickets.