Opened 11 years ago

Closed 10 years ago

#5641 closed defect (invalid)

Playback Stops After Jump, FastForward

Reported by: mike@… Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythtv Version: 0.21-fixes
Severity: high Keywords:
Cc: Ticket locked: no

Description

Hi Guys

I just upgraded svn tag 18091 version of Mythtv. It using a build that a friend builds

The issue I'm having is that playback stops after a jump forward/back or fastforward/fastreverse. Once this happens I can not access mythweb for a time also.

It seem as if mythbackend locks up for a period of time. Once this time period expires mythfrontend drops back to the menu screens

[root@pvr-master ~]# mythbackend --version Please include all output in bug reports. MythTV Version : exported MythTV Branch : branches/release-0-21-fixes Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in:

linux release using_oss using_alsa using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_opengl using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live using_xvmc_pbuffer

[root@pvr-master ~]#

[root@pvr-master ~]# mythfrontend --version Please include all output in bug reports. MythTV Version : exported MythTV Branch : branches/release-0-21-fixes Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in:

linux release using_oss using_alsa using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_opengl using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live using_xvmc_pbuffer

[root@pvr-master ~]#

Change History (10)

comment:1 Changed 11 years ago by Dibblah

Status: newinfoneeded_new

This sounds very much like a corrupt seektable.

If it is still an issue with current trunk, please run optimize_mythdb.pl

Otherwise: mythfrontend -v playback mythbackend -v record,network

comment:2 Changed 11 years ago by mike@…

Hi Dibblah

I ran the script no change, I've upgraded to 0.21-fixs svn id 19467, the problem seems to have gotten much worse. Now I can not fast forward past 3x and even at 3x when I try to move back to normal play mode it also does not play normally

Playback options below give the same result (using a nvida 8500 gt) Playback, decoder: libmpeg2, render: opengl, OSD render: opengl2 Playback, decoder: standard, render: opengl, OSD render: opengl2 logs of > x3 2009-02-01 22:53:54.643 NVP: Waiting for prebuffer.. 4 AAAAAAAAAAAAAAALAuAALAAAAAAAAAA 2009-02-01 22:53:54.645 AO: 58592 bytes free on soundcard 2009-02-01 22:53:54.647 AO: 59008 bytes free on soundcard 2009-02-01 22:53:54.649 AO: 59392 bytes free on soundcard 2009-02-01 22:53:54.651 AO: 59808 bytes free on soundcard 2009-02-01 22:53:54.653 AO: 60192 bytes free on soundcard 2009-02-01 22:53:54.655 AO: 60608 bytes free on soundcard 2009-02-01 22:53:54.657 AO: 61024 bytes free on soundcard 2009-02-01 22:53:54.660 AO: 61408 bytes free on soundcard 2009-02-01 22:53:54.662 AO: 61824 bytes free on soundcard 2009-02-01 22:53:54.664 AO: 58144 bytes free on soundcard 2009-02-01 22:53:54.666 AO: 58528 bytes free on soundcard 2009-02-01 22:53:54.668 AO: 58944 bytes free on soundcard 2009-02-01 22:53:54.670 AO: 59360 bytes free on soundcard 2009-02-01 22:53:54.672 AO: 59776 bytes free on soundcard 2009-02-01 22:53:54.674 AO: 60192 bytes free on soundcard 2009-02-01 22:53:54.676 AO: 60576 bytes free on soundcard 2009-02-01 22:53:54.679 AO: 60960 bytes free on soundcard 2009-02-01 22:53:54.681 AO: 61376 bytes free on soundcard

Logs of 3x and play 009-02-01 22:57:50.169 AO: audio waiting for buffer to fill: have 2048 want 4096 2009-02-01 22:57:50.171 SetAudiotime? set=1233491270.171603, audt=11714117 atc=11714127 tb=2048 sb=0 eds=4800000 abps=4 s f=1 2009-02-01 22:57:50.171 AO: audio waiting for buffer to fill: have 2048 want 4096 2009-02-01 22:57:50.173 SetAudiotime? set=1233491270.173768, audt=11714117 atc=11714127 tb=2048 sb=0 eds=4800000 abps=4 s f=1 2009-02-01 22:57:50.173 AO: audio waiting for buffer to fill: have 2048 want 4096 2009-02-01 22:57:50.175 SetAudiotime? set=1233491270.175977, audt=11714117 atc=11714127 tb=2048 sb=0 eds=4800000 abps=4 s f=1 2009-02-01 22:57:50.176 AO: audio waiting for buffer to fill: have 2048 want 4096 2009-02-01 22:57:50.178 SetAudiotime? set=1233491270.178168, audt=11714117 atc=11714127 tb=2048 sb=0 eds=4800000 abps=4 s f=1 2009-02-01 22:57:50.178 AO: audio waiting for buffer to fill: have 2048 want 4096 2009-02-01 22:57:50.180 SetAudiotime? set=1233491270.180331, audt=11714117 atc=11714127 tb=2048 sb=0 eds=4800000 abps=4 s f=1 2009-02-01 22:57:50.180 AO: audio waiting for buffer to fill: have 2048 want 4096

comment:3 Changed 11 years ago by Dibblah

This still sounds like you don't have a valid seektable. Can you run mythcommflag -f <recording filename> on a single recording and see if that fixes it?

comment:4 Changed 11 years ago by anonymous

Hi All

I ran this on all my recordings and it would seem to have fixed the total lockups but the stops and starts after fastforward are still there.

So I think the new issue was covering up the old issue

Mike

comment:5 Changed 11 years ago by sphery <mtdean@…>

Did you either run optimize_mythdb.pl or do a Repair Tables from MythWeb before rebuilding the seektable?

Did you rebuild the seektable as directed in my e-mail to you and the dev list ( http://www.gossamer-threads.com/lists/mythtv/dev/369030#369030 )? See also http://www.mythtv.org/wiki/Repairing_the_Seektable . If not, please do so and see if it fixes the issues.

Thanks.

comment:6 Changed 11 years ago by anonymous

Hi

I have run all the requested scripts. Firstly the optimize_mythdb.pl, then someone I think you said that a 'mythcommflag --rebuild -f ' was needed.

This was run on every file in my myth file store.

Mike

comment:7 Changed 11 years ago by Dibblah

Is this problem limited to the OpenGL renderer?

comment:9 Changed 11 years ago by anonymous

Please go back to the initial report of issue, it would see as if the issues following this report where caused by the upgrade and the seektable issues.

The pausing seem to happen with any playback method.

comment:10 Changed 11 years ago by danielk

Anon, is pulseaudio running? If so please install the libpulse-dev and ./configure, compile and install the latest 0.21-fixes and report if the problem has been resolved.

comment:11 Changed 10 years ago by stuartm

Resolution: invalid
Status: infoneeded_newclosed

No response from submitter, closing.

Note: See TracTickets for help on using tickets.