Opened 10 years ago

Closed 10 years ago

#5670 closed defect (fixed)

Wrong colours in preview window on ARM

Reported by: koen@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

The colours are wrong in the preview window when running on ARM. Screenshot attached.

Attachments (1)

mythtv-wrong-colours.jpg (182.7 KB) - added by koen@… 10 years ago.
screenshot of wrong colours

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by koen@…

Attachment: mythtv-wrong-colours.jpg added

screenshot of wrong colours

comment:1 Changed 10 years ago by Dibblah

This is caused by the colorspace conversion used by Myth being broken on anything which does not support MMX. Unfortunately, this bug has existed for a very long time and has little developer focus. If you have a patch, I am sure it would be applied :)

comment:2 Changed 10 years ago by Dibblah

Priority: majorminor

comment:3 Changed 10 years ago by stuartm

Status: newinfoneeded_new

Could someone confirm that this is still a problem with trunk, especially following the -vid branch merge.

comment:4 Changed 10 years ago by Dibblah

Status: infoneeded_newnew

This will still be an issue. The problem is in the colorspace conversion done in /mythtv/libs/libmythtv/yuv2rgb.cpp - MMX works, non-MMX doesn't. The bug has been present since I've been involved with Myth, but as I said is not 'interesting' to most people.

comment:5 Changed 10 years ago by danielk

Severity: mediumlow
Version: 0.21-fixeshead

comment:6 Changed 10 years ago by Janne Grunau

(In [20763]) fix unacellerated yuv2argb byte order for little endian.

Fixes the wrong colors in the live preview for ARM. Refs #5670

comment:7 Changed 10 years ago by Janne Grunau

Resolution: fixed
Status: newclosed

(In [20767]) fixes wrong colors in live-preview, Fixes #5670

forward ports [20763] and adds configure check for disabled mmx on x86. Throws an error if MMX is diasbled without another option which hopefully makes it clear that MMX should only be disabled for debugging purposes. I assume nobody wants to use mythtv on a x86 cpu without mmx anymore.

Note: See TracTickets for help on using tickets.