Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#5703 closed defect (fixed)

MythTV unable to use disecq (Only first disecq switch works)

Reported by: skerit@… Owned by: danielk
Priority: minor Milestone: 0.21.1
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords: disecq, dvb-s, multiproto, switch
Cc: Ticket locked: no

Description

I have submitted this error before, but I was using a patched version of MythTV then.

The maintainer of the multiproto driver has added support for the old DVB API.

This means unpatched programs work with newer cards (like my S2-3200) I have tested this in an unpatched Kaffeine and I'm able to tune channels with ease. I'm also able to make use of disecq switch 2, 3 & 4

However, in MythTV only the first one works. I CAN scan the other switches, but I can not tune them.

It also complains about the program not being found in PAT, and that I have to rescan my transponders, but this does nothing, except take a long time to complete.

I have also tried this on the latest SVN trunk of mythtv.

2008-09-07 13:12:27.052 Current Schema Version: 1214
2008-09-07 13:12:27.058 Preview Error: Previewer file '/video/31611_20080907131101.mpg' is not valid.
2008-09-07 13:12:27.059 Preview Error: Run() file not local: '/video/31611_20080907131101.mpg'
2008-09-07 13:12:27.064 Preview Error: Preview process not ok.
			fileinfo(/video/31611_20080907131101.mpg.png) exists: 0 readable: 0 size: 0
2008-09-07 13:12:27.416 DVBSM(0), Warning: Can not count Uncorrected Blocks
			eno: Bewerking wordt niet ondersteund (95)
2008-09-07 13:12:27.422 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 15 min
2008-09-07 13:12:28.064 Program #10354 not found in PAT!
Program Association Table
 PSIP tableID(0x0) length(57) extension(0x420)
      version(29) current(1) section(0) last_section(0)
         tsid: 1056
 programCount: 12
  program number     0 has PID 0x  10   data  0x 0 0x 0 0xe0 0x10
  program number 29950 has PID 0x 400   data  0x74 0xfe 0xe4 0x 0
  program number 29962 has PID 0x 40b   data  0x75 0x a 0xe4 0x b
  program number 29961 has PID 0x 40a   data  0x75 0x 9 0xe4 0x a
  program number 29958 has PID 0x 408   data  0x75 0x 6 0xe4 0x 8
  program number 29957 has PID 0x 407   data  0x75 0x 5 0xe4 0x 7
  program number 29954 has PID 0x 404   data  0x75 0x 2 0xe4 0x 4
  program number 29953 has PID 0x 403   data  0x75 0x 1 0xe4 0x 3
  program number 29956 has PID 0x 406   data  0x75 0x 4 0xe4 0x 6
  program number 29955 has PID 0x 405   data  0x75 0x 3 0xe4 0x 5
  program number 29952 has PID 0x 402   data  0x75 0x 0 0xe4 0x 2
  program number 29951 has PID 0x 401   data  0x74 0xff 0xe4 0x 1

2008-09-07 13:12:28.639 ProcessPAT: Program not found in PAT. 
			Rescan your transports.
2008-09-07 13:12:28.639 Desired program #10354 not found in PAT.
			Can Not create single program PAT.
2008-09-07 13:12:35.306 TVRec(1): Changing from WatchingLiveTV to None
2008-09-07 13:12:35.400 Finished recording Onbekend: channel 11354
2008-09-07 13:12:35.462 Finished recording Onbekend: channel 11354


Attachments (1)

diseqc.patch (435 bytes) - added by jo@… 12 years ago.
patch diseqc

Download all attachments as: .zip

Change History (13)

comment:1 Changed 12 years ago by skerit@…

I have to add that MythTV does get EIT data from these other disecq switches (All the BBC channels are filled, for example.)

I also sometimes get a "Partial lock", never a complete one though.

comment:2 Changed 12 years ago by jo@…

I found the problem for this. I attached a path.

Greetz, Jo

Changed 12 years ago by jo@…

Attachment: diseqc.patch added

patch diseqc

comment:3 Changed 12 years ago by danielk

Owner: changed from Isaac Richards to danielk
Priority: blockerminor
Status: newassigned

comment:4 Changed 12 years ago by skerit@…

I can confirm the patch works brilliantly (It was just a small error in the code, apparently?)

comment:5 Changed 12 years ago by danielk

Status: assignedinfoneeded

The patch is incorrect, it breaks the sending of some commands, and breaks retries on errors for others. This needs to be debugged further, the first step would be to find out which command is failing. Finding out why would be useful as well.

comment:6 Changed 12 years ago by danielk

Resolution: invalid
Status: infoneededclosed

no info provided & patch incorrect. Reopen when previously requested info is available.

comment:7 Changed 12 years ago by jo@…

Hi Daniel,

If I don't do the patch with my multytenne, I can't swith the diseqc port. What commands are broken if you apply the patch ? I tested s2api this weekend, and I need also the patch. I am not alone, see http://svn.mythtv.org/trac/ticket/5882#comment:37

Greets, Jo

comment:8 Changed 12 years ago by jo@…

I forget to mention, this is in trunk, not 21-fixes

comment:9 Changed 11 years ago by anonymous

Hello,

I can confirm the issue with the multytenne dish.

The problem is, I think, in the repeated DiSeqC command. The first command itself is correct. Mythtv debugging only logs the first command sent, not the repeats, so I can not confirm if the repeated commands are correct.

The UI of Mythtv-setup requires to send at least 1 repeat. I don't think this is needed as per DiSeqC specifications. Repeats are only for cascading multiple switches.

A fix would be to allow in mythtv-setup to specify "0" (zero) as a valid number of repeats.

When changing the "cmd_repeat" column in the DiSeqC_tree table of the database manualy to "0", the multytenne dish works perfectly. This is more or less what the patch tried to do: not sending a repeated command.

I didn't do any testing, but I think this is one or 2 things:

  • A timing issue where the repeated command is simply sent to quickly for the multytenne (The DiSeqC specification says "at least" 15ms between DiSeqC messages, mythtv does exactly 15ms.)
  • Or the repeated commands are wrong. (There is a lot of DiSeqC equipment that simply ignore repeated commands...)

Would it be possible to change the user interface of mythtv-setup to make it possible to send 0 repeats?

comment:10 Changed 11 years ago by danielk

Resolution: invalid
Status: closednew

comment:11 Changed 11 years ago by danielk

Resolution: fixed
Status: newclosed

(In [20880]) Fixes #5703. Allow DiSEqC repeat count to be set to 0.

comment:12 Changed 11 years ago by Peter Bienstman <Peter.Bienstman@…>

Has this fix actually worked for anyone? I seem to have similar issues, but it could be something different: http://svn.mythtv.org/trac/ticket/7728

Note: See TracTickets for help on using tickets.