Opened 12 years ago

Closed 12 years ago

#5707 closed defect (wontfix)

MythBrowser plugin incompatible with Firefox

Reported by: mludowise+code@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythbrowser Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Enter Firefox as the custom browser in Web Settings for the MythBrowser? plugin. Go to the Web menu item and open any website, nothing happens.

It seems that MythBrowser? runs the browser with the -h option. This configures the height for MythBrowser?, but prompts for the help in Firefox which prevents Firefox from starting.

If MythBrowser? used the -height and -width options instead of -h and -w, the same as Firefox, then this would configure the width and height for Firefox when running the browser command.

Alternatively you could allow the user to enter in width and height using the % notation in the settings. For example, the browser settings could be "mythbrowser -h %h -w %w" or "firefox -height %h -width %w". This way it would be compatible with any browser the user chooses.

Configuration: Mythbuntu 8.04.1 MythTV 0.21 Firefox 3.0.1

Change History (2)

comment:1 Changed 12 years ago by anonymous

'-geometry %wx%h' is probably more compatible with all browsers (on X11 clients).

comment:2 Changed 12 years ago by Dibblah

Resolution: wontfix
Status: newclosed

MythBrowser? has been rewritten in trunk to use QT's Webkit. This issue doesn't apply to trunk and is not a regression.

Note: See TracTickets for help on using tickets.