Opened 11 years ago

Closed 11 years ago

#5708 closed defect (fixed)

mythmusic no longer plays audio cd's

Reported by: leoweppelman@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythmusic Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Since I updated to the trunk, playing audio cd's is no longer possible. The frontend just hangs. The cause is probably in incompatibility between qt3 & qr4. The filename passed to the cddecoder is from the from '<trackno>.cda'. 'tracknum = filename.toUInt();' does not return the integer part of the filename but bails out returning 0. The attached patch fixes this.

Attachments (1)

diff (437 bytes) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by anonymous

Attachment: diff added

comment:1 Changed 11 years ago by Nigel

Resolution: fixed
Status: newclosed

(In [18260]) Fix CD playing hang after Qt4. Patch from Leo Weppelman (plus slight changes by me). Closes #5708

Note: See TracTickets for help on using tickets.