Opened 11 years ago

Closed 11 years ago

#5724 closed defect (wontfix)

callsign/chansign from TVRec::GetNextProgram is not correctly utf8 escaped.

Reported by: elupus@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi,

while working on xbmc's myth frontend, i came across problems with the utf8 handling of call signs when using GET_NEXT_PROGRAM_INFO.

in TVRec::GetNextProgram? there is two places where callsign is assigned, without using QString::fromUtf8(). This is different from how other places callsign/chansign are retrieved.

I assume things like this are stored in UTF8 in the database (as they ended up after i scanned in Sweden). Thus the callsign should also have fromUtf8 command on it.

The problem is also visible in mythfrontend, in channel editor during TV playback. Just rename a channel inside mythconverg.channel to a utf8 encoded name, and you will see the problem.

Change History (2)

comment:1 Changed 11 years ago by anonymous

If you could bump version number when you fix this I'd be much obliged. Thou it might seem silly to you, I've worked around it in our libcmyth based client.

Since QString does a latin1->utf8 conversion if you don't do fromUtf8, we just do a latin1->utf8, which luckily retains the utf8 encoding of the original data. Currently this is based on protocol being <= 40.

comment:2 Changed 11 years ago by danielk

Resolution: wontfix
Status: newclosed

Fixing this in 0.21-fixes will cause compat problems and this is fixed in trunk.

Note: See TracTickets for help on using tickets.