Opened 11 years ago

Closed 11 years ago

#5727 closed defect (duplicate)

Channel-zapping in frontend does not work

Reported by: heldal@… Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: high Keywords:
Cc: Ticket locked: no

Description

The back-end fails to tune to a the selected channel when zapping with arrow-up/dn+enter from mythfrontend. At first try it changes to a (possibly the first) available unencrypted channel, a channel that isn't even set to be visible in the channel configuration. Subsequent attempt to change channel have no effect.

Changing channels from the program-guide (via the menu) works (if enabled in the config). Pre-programmed recordings are also able to tune to any channel.

This is found using mythtv from svn rev 18336 with a Hauppauge HVR4000 DVB-Hybrid card in DSB-S mode using a recent multproto driver through its compatibilty api. Vanilla mythtv 0.21 works fine on the same hardware/os/drivers.

Change History (4)

comment:1 Changed 11 years ago by heldal@…

Can add that tuning with <channel-no>+enter also works.

comment:2 Changed 11 years ago by rafmoslin@…

This is a duplicate of #5194

comment:3 Changed 11 years ago by anonymous

Agree it's a duplicate. Missed it because #5194 refers to DVB-T and this is DVB-S. Log entries confirm the relation:

2008-09-19 20:36:51.314 DTVSM(/dev/dvb/adapter1/frontend0) Error: Wrong PMT; pmt->pn(952) desired(4006)

In this case I end up with 4006 whichever one is chosen (here 952), not the first available channel as indicate in #5194.

And the workaround attached to #5194 works for me too.

comment:4 Changed 11 years ago by Dibblah

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.