Opened 11 years ago

Closed 11 years ago

#5728 closed defect (invalid)

Error

Reported by: anonymous Owned by: xris
Priority: minor Milestone: unknown
Component: mythweb Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by paulh)

Backtrace:

datetime: 2008-09-20 17:37:21 (CEST) errornum: 256

error type: User Error

error string: Unable to connect to mythbackend, is it running?

filename: /usr/share/mythtv/mythweb/includes/mythbackend.php

error line: 39

==========================================================================

Backtrace:

    file:  /usr/share/mythtv/mythweb/includes/mythbackend.php
    line:  39
   class:  
function:  trigger_error
    type:  
    args:  Array
(
    [0] => Unable to connect to mythbackend, is it running?

    [1] => 256
)

    file:  /usr/share/mythtv/mythweb/includes/init.php
    line:  52
   class:  
function:  require_once
    type:  
    args:  Array
(
    [0] => /usr/share/mythtv/mythweb/includes/mythbackend.php
)

    file:  /usr/share/mythtv/mythweb/mythweb.php
    line:  20
   class:  
function:  require_once
    type:  
    args:  Array
(
    [0] => /usr/share/mythtv/mythweb/includes/init.php
)


==========================================================================

$_SESSION: Array
(
    [language] => English
)

==========================================================================

$_SERVER: Array
(
    [REDIRECT_STATUS] => 200
    [HTTP_HOST] => 127.0.0.1:6544
    [HTTP_USER_AGENT] => Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
    [HTTP_ACCEPT] => text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5
    [HTTP_ACCEPT_ENCODING] => gzip,deflate
    [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7
    [HTTP_KEEP_ALIVE] => 300
    [HTTP_CONNECTION] => keep-alive
    [HTTP_COOKIE] => mythweb_id=90c7ebcc90c6ca4fed978b9d438023dd; TorrentFlux=78af65ee494d7bd87cb00eb40ca4aefc
    [PATH] => /usr/local/bin:/usr/bin:/bin
    [SERVER_SIGNATURE] => <address>Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.3 with Suhosin-Patch Server at 127.0.0.1 Port 80</address>

    [SERVER_SOFTWARE] => Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.3 with Suhosin-Patch
    [SERVER_NAME] => 127.0.0.1
    [SERVER_ADDR] => 127.0.0.1
    [SERVER_PORT] => 80
    [REMOTE_ADDR] => 127.0.0.1
    [DOCUMENT_ROOT] => /var/www
    [SERVER_ADMIN] => webmaster@localhost
    [SCRIPT_FILENAME] => /var/www/mythweb/mythweb.php
    [REMOTE_PORT] => 44058
    [REMOTE_USER] => rhk
    [AUTH_TYPE] => Digest
    [REDIRECT_URL] => /mythweb/
    [GATEWAY_INTERFACE] => CGI/1.1
    [SERVER_PROTOCOL] => HTTP/1.1
    [REQUEST_METHOD] => GET
    [QUERY_STRING] => 
    [REQUEST_URI] => /mythweb/
    [SCRIPT_NAME] => /mythweb/mythweb.php
    [PHP_SELF] => /mythweb/mythweb.php
    [PHP_AUTH_DIGEST] => username="rhk", realm="MythTV", nonce="fn5cl1VXBAA=3a12d6a635ba8877d5db994592da965bb4359b9d", uri="/mythweb/", algorithm=MD5, response="80ace22388af6c0cb4ef99d81eb38c0a", qop=auth, nc=00000002, cnonce="cba649c1e20c04c2"
    [REQUEST_TIME] => 1221925041
    [argv] => Array ( )
    [argc] => 0
    [STATUS] => 200
    [URL] => /mythweb/
)

Attachments (1)

dmesg (25.0 KB) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by anonymous

Attachment: dmesg added

comment:1 Changed 11 years ago by paulh

Component: mythtvmythweb
Description: modified (diff)
Owner: changed from Isaac Richards to xris

Are you sure mythbackend was running?

Is this reproducible?

Which version is this.

comment:2 Changed 11 years ago by xris

Resolution: invalid
Status: newclosed

This is not a bug -- this error only shows up (appropriately) only when the backend isn't running, or is in a state (e.g. blocked by firewall) where mythweb can't talk to it.

Note: See TracTickets for help on using tickets.