Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5730 closed defect (fixed)

h.264 (BBC HD) recording length incorrect, skip not working

Reported by: tlawton@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

My efforts with h.264 content have been varied for a while, but until recently it was possible to record and watch h.264 content (from DVB-S) on this box.

Using svn 18322 with skiploopfilter patch

HD content records successfully, but on playback the recording length is indicated incorrectly. The first recording (52 minutes) displays as 4:18 (file is 7Gb and mplayer can play past this point); the second recording (81 minutes) displays as 6:44. In mythweb both recordings appear to have the correct length. When mythtv hits what it thinks is the length of the recording, it stops as if it has come to the end of a file as normal.

In addition, any attempt to skip forwards during playback results in the stream restarting from the beginning. The counter however increases as if the skip was successful. (ie you end up watching the start of the show with 00:30 etc showing on the OSD)

Apologies if this is the result of the skiploopfilter patch (I'm not really sure how it would be) - but HD isn't watchable on this system without it; I'm hoping someone else can reproduce this.

Attachments (3)

mythfrontend-h.264-wronglength.log (45.3 KB) - added by anonymous 11 years ago.
mythfrontend -v playback with each of the two shows
mythfrontend-h.264-skipwrong.log (53.9 KB) - added by anonymous 11 years ago.
mythfrontend -v playback trying to skip forwards (30s at a time)
h264utils.patch (384 bytes) - added by jppoet@… 11 years ago.
Possible fix 1

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by anonymous

mythfrontend -v playback with each of the two shows

Changed 11 years ago by anonymous

mythfrontend -v playback trying to skip forwards (30s at a time)

comment:1 Changed 11 years ago by rafmoslin@…

Me too! Running the latest svn (without the skiploop patch) and the recordings are also from BBC HD, used to work just fine. Rebuilding the keyframe index does not help either.

comment:2 Changed 11 years ago by anonymous

I've noticed this as well.

When it's recording a h264 channel I get

'[h264 @ 0x7fe0ff97d5b0]number of reference frames exceeds max (probably corrupt input), discarding one'

and

'KeyframeSequencer::decode_Header: SPS has not been parsed!'

in the backend log.

comment:3 Changed 11 years ago by anonymous

When using Mythbuntu 8.04.1 the mythtv packages on the CD (0.21.0+fixes16838-0ubuntu3.1) work fine but when you upgrade packages it installs '0.21.0+fixes18207-0ubuntu4~hardy1' which has this problem.

comment:4 Changed 11 years ago by anonymous

Re comment #3:

I've backported r18104 from trunk to the MythTV packages. That changeset might be to blame. You can try rebuilding without that patch:

  • add a deb-src repository to your sources.list
  • 'apt-get source mythtv' to download the source
  • edit debian/patches/00list and comment out 24_fix_h264_frame_counting.dpatch with a hash (#)
  • run debuild -S
  • wait && install packages

If you have any questions, these are best asked on mythtv-dev.

Another reason for such problems might be the recent h264 sync.

comment:5 Changed 11 years ago by anonymous

Looking back at my recordings this problems seems to have appeared late August - early September (before the 4th September).

comment:6 in reply to:  4 Changed 11 years ago by anonymous

Replying to anonymous:

It was '24_fix_h264_frame_counting.dpatch' that caused the problem in Mythbuntu. Commenting out the patch and rebuilding the packages has fixed it.

Thanks

Changed 11 years ago by jppoet@…

Attachment: h264utils.patch added

Possible fix 1

comment:7 Changed 11 years ago by jppoet@…

I am unable to test the attached patch. Can someone with this problem give it a try?

comment:8 Changed 11 years ago by anonymous

I'm not sure exactly what the intended effect of this patch is (basically I'm not sure whether this bug relates to recording or playback).

Files recorded previously still exhibit exactly the same (wrong) behaviour. I've just set a programme recording and it appears to be behaving correctly (however previously I didn't try watching a programme whilst it was recording).

I'll report back when this recording finishes; unless the patch was intended to fix the old recordings too.

comment:9 Changed 11 years ago by jppoet@…

Sorry, I should have been clear about that. This patch will NOT fix previous recordings, only new ones (I hope).

comment:10 Changed 11 years ago by Janne Grunau

Resolution: fixed
Status: newclosed

(In [18542]) Fix position map for some H.264 streams

This will fix only new recordings, old recordings can be fixed by mythcommflag --rebuild. Fixes #5730

patch by John Poet <jppoet AT gmail DOT com>

comment:11 Changed 11 years ago by anonymous

Thanks! Seems to be working fine now with the patch

Note: See TracTickets for help on using tickets.