Opened 11 years ago

Closed 11 years ago

#5816 closed defect (wontfix)

Guide rating for programa data from tv_grab_uk_rt produces nonsensical results

Reported by: lists@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords: guide rating radiotimes tv_grab_uk_rt
Cc: Ticket locked: no

Description

Guide ratings from tv_grab_uk_rt are in multiples of 0.2 (0, 0.2, 0.4, 0.6, 0.8 and 1), but programinfo.cpp multiplies them by 4, giving odd guide ratings for shows. Should there be a check for the data source somewhere around line 639 to multiply the guide rating by 5 for data from the UK RadioTimes? grabber, and 4 for all others so the displayed rating is an integer, rather than multiples of 0.8 as they are at the moment?

Are there other grabbers that provide ratings as multiples of 0.2?

I may have picked the wrong root cause of the issue here, perhaps the grabber is producing the less-useful numbers. I'm no C programmer, hence not submitting a patch of my own.

Change History (1)

comment:1 Changed 11 years ago by stuartm

Resolution: wontfix
Status: newclosed

Adding grabber specific hacks is not a solution and won't happen, we've spent the last two years removing such hacks because they are a pain to maintain.

XMLTV makes no recommendation on the multiples used,merely that the rating should be in the format "N / M". It doesn't specify that N or M should be integers, but that is implied. We might store the value as a string instead of a float but that has display issues - themers can't easily represent differing schemes with star images for example.

On systems with multiple and differing different sources you'd have rating information which didn't relate in a straight comparison. You wouldn't be able to setup recording rules for all films with 5 stars, if one scheme was rated out of 5 and the other out of 100.

I'm not really sure why Myth uses a 4 star rating internally, by far the most common multiple is 5 (5,10,100). I think this could be changed to 5 or 10 but it needs some discussion first. It would at least match up with other areas both mythmusic and mythvideo use 10 and this sort of UI consistency is what we're moving towards.

Note: See TracTickets for help on using tickets.