Opened 12 years ago

Closed 12 years ago

#5824 closed defect (duplicate)

No way to release hung tuner.

Reported by: joe@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords: hung tuner
Cc: Ticket locked: no

Description

I frequently experience a situation where a frontend that is viewing livetv get's disconnected unexpectedly causing the tuner it was using to remain in "recording live tv" mode and therefore unavailable. For some reason, even scheduled recordings will not terminate the live tv recording. The only way I know that works is to restart the backend service... however this is a major inconvienance if I am trying to free a tuner so a recording isn't missed and another tuner is active.

This is a pretty serious problem. I was on a two week business trip and returned home to find that 4 of my 5 tuners were hung and tons of shows were missed. It seems that my children are the primary cause of the problems (turning off the computer without quiting playback I think.)

The following things need to be fixed:

  1. a manual termination of recordings by tuner should be added (perhaps in the system status/tuner status page)
  1. the recording system should track which frontend initiated the live-tv recording and it should occasionally verify that that frontend is on and actively watching that file.

Change History (1)

comment:1 Changed 12 years ago by kkuphal

Resolution: duplicate
Status: newclosed

Duplicate of #2960

Note: See TracTickets for help on using tickets.