Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#5832 closed defect (wontfix)

segmentation fault when scanning channels for DVB

Reported by: glemsom@… Owned by: danielk
Priority: major Milestone: 0.21.1
Component: dvb Version: 0.21-fixes
Severity: high Keywords: dvb segmentation fault scanning scan
Cc: Ticket locked: yes

Description

mythtv-setup is unable to scan for DVB-C channels - and causes a segmentation fault. Steps:

  1. Close mythbackend.
  2. Start mythtv-setup
  3. Configure DVB-C card and some video-source (no grabber)
  4. Goto Input connections - and assosiate the video-source.
  5. Select "Full Scan of Existing Transports" or Full Scan (I ised: Freq: 143000000, Symbolrate: 6875000)

Hit "Next" and mythtv-setup will cause a segmentation fault

Attachments (1)

gdb-20081031.txt (8.3 KB) - added by charles 11 years ago.
gdb output of transport scan

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by charles

I can confirm. I'll try to debug.

comment:2 Changed 11 years ago by charles

I'm running Ubuntu 8.10, with mythtv 0.21+fixes 18722. I recompiled with debug symbols.

The attached gdb output is generated after scanning a known transport for channels (using DVB-C). Scan works perfect, updates are processed, but the usual 'Finish' screen crashes/segfaults.

More information needed?

Changed 11 years ago by charles

Attachment: gdb-20081031.txt added

gdb output of transport scan

comment:3 Changed 11 years ago by development@…

I think this problem is related to multiple core cpu.

With "taskset -c 0 mythtv-setup" (running only on the first cpu core) dvb scan ends without errors.

Note: It appear both on DVB-S and DVB-T. Note2: At the moment I cannot reproduce it...

comment:4 Changed 11 years ago by Dibblah

Status: newassigned

comment:5 Changed 11 years ago by danielk

Resolution: wontfix
Status: assignedclosed

This segfault doesn't happen with the new scanner in the mythtv-channel-scan branch, and I've tried unsuccessfully to fix it with the old scanner one too many times, so this is a wontfix. As soon as the issues with the new scanner wrt to DVB-X are resolved we'll replace the current non-thread-safe scanner with the new thread-safe channel scanner...

comment:7 Changed 10 years ago by stuartm

Ticket locked: set
Note: See TracTickets for help on using tickets.