Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5841 closed defect (fixed)

Error when compiling rev 18770

Reported by: Benoit LORAND <benoit.lorand@…> Owned by: danielk
Priority: blocker Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

ccache g++ -c -pipe -march=pentiumpro -fomit-frame-pointer -O3 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -DSTDC_CONSTANT_MACROS -I/usr/include/freetype2 -D_REENTRANT -DPIC -fPIC -DMMX -Di386 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DUSING_OSS -DUSING_H264TOOLS -DUSING_X11 -DUSING_XV -DUSING_XVMC -DUSING_XVMC_PBUFFER -DUSING_OPENGL -DUSING_XVMC_OPENGL -DUSING_OPENGL_VSYNC -DUSING_OPENGL_VIDEO -DUSING_FRONTEND -DUSING_FFMPEG_THREADS -DUSING_V4L -DUSING_IPTV -DUSING_HDHOMERUN -DUSING_IVTV -DUSING_HDPVR -DUSING_DVB -DUSING_BACKEND -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/opt/qt-4.4.1/mkspecs/linux-g++ -I. -I/opt/qt-4.4.1/include/QtCore -I/opt/qt-4.4.1/include/QtCore -I/opt/qt-4.4.1/include/QtNetwork -I/opt/qt-4.4.1/include/QtNetwork -I/opt/qt-4.4.1/include/QtGui -I/opt/qt-4.4.1/include/QtGui -I/opt/qt-4.4.1/include/QtXml -I/opt/qt-4.4.1/include/QtXml -I/opt/qt-4.4.1/include/QtSql -I/opt/qt-4.4.1/include/QtSql -I/opt/qt-4.4.1/include -I/opt/mythtv/include -I/usr/include -I/srv/xorg/include -I/srv/lirc/include -I/srv/xorg/include -I../.. -I.. -I. -I../libmyth -I../libavcodec -I../libavutil -I../libmythmpeg2 -Idvbdev -Impeg -Iiptv -I../libmythlivemedia/BasicUsageEnvironment/include -I../libmythlivemedia/groupsock/include -I../libmythlivemedia/liveMedia/include -I../libmythlivemedia/UsageEnvironment/include -I../libmythdb -I../libmythui -I/srv/xorg/include -I. -I. -o moc_scanwizard.o moc_scanwizard.cpp ccache g++ -c -pipe -march=pentiumpro -fomit-frame-pointer -O3 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -DSTDC_CONSTANT_MACROS -I/usr/include/freetype2 -D_REENTRANT -DPIC -fPIC -DMMX -Di386 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DUSING_OSS -DUSING_H264TOOLS -DUSING_X11 -DUSING_XV -DUSING_XVMC -DUSING_XVMC_PBUFFER -DUSING_OPENGL -DUSING_XVMC_OPENGL -DUSING_OPENGL_VSYNC -DUSING_OPENGL_VIDEO -DUSING_FRONTEND -DUSING_FFMPEG_THREADS -DUSING_V4L -DUSING_IPTV -DUSING_HDHOMERUN -DUSING_IVTV -DUSING_HDPVR -DUSING_DVB -DUSING_BACKEND -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/opt/qt-4.4.1/mkspecs/linux-g++ -I. -I/opt/qt-4.4.1/include/QtCore -I/opt/qt-4.4.1/include/QtCore -I/opt/qt-4.4.1/include/QtNetwork -I/opt/qt-4.4.1/include/QtNetwork -I/opt/qt-4.4.1/include/QtGui -I/opt/qt-4.4.1/include/QtGui -I/opt/qt-4.4.1/include/QtXml -I/opt/qt-4.4.1/include/QtXml -I/opt/qt-4.4.1/include/QtSql -I/opt/qt-4.4.1/include/QtSql -I/opt/qt-4.4.1/include -I/opt/mythtv/include -I/usr/include -I/srv/xorg/include -I/srv/lirc/include -I/srv/xorg/include -I../.. -I.. -I. -I../libmyth -I../libavcodec -I../libavutil -I../libmythmpeg2 -Idvbdev -Impeg -Iiptv -I../libmythlivemedia/BasicUsageEnvironment/include -I../libmythlivemedia/groupsock/include -I../libmythlivemedia/liveMedia/include -I../libmythlivemedia/UsageEnvironment/include -I../libmythdb -I../libmythui -I/srv/xorg/include -I. -I. -o moc_scanwizardhelpers.o moc_scanwizardhelpers.cpp ccache g++ -c -pipe -march=pentiumpro -fomit-frame-pointer -O3 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -DSTDC_CONSTANT_MACROS -I/usr/include/freetype2 -D_REENTRANT -DPIC -fPIC -DMMX -Di386 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DUSING_OSS -DUSING_H264TOOLS -DUSING_X11 -DUSING_XV -DUSING_XVMC -DUSING_XVMC_PBUFFER -DUSING_OPENGL -DUSING_XVMC_OPENGL -DUSING_OPENGL_VSYNC -DUSING_OPENGL_VIDEO -DUSING_FRONTEND -DUSING_FFMPEG_THREADS -DUSING_V4L -DUSING_IPTV -DUSING_HDHOMERUN -DUSING_IVTV -DUSING_HDPVR -DUSING_DVB -DUSING_BACKEND -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/opt/qt-4.4.1/mkspecs/linux-g++ -I. -I/opt/qt-4.4.1/include/QtCore -I/opt/qt-4.4.1/include/QtCore -I/opt/qt-4.4.1/include/QtNetwork -I/opt/qt-4.4.1/include/QtNetwork -I/opt/qt-4.4.1/include/QtGui -I/opt/qt-4.4.1/include/QtGui -I/opt/qt-4.4.1/include/QtXml -I/opt/qt-4.4.1/include/QtXml -I/opt/qt-4.4.1/include/QtSql -I/opt/qt-4.4.1/include/QtSql -I/opt/qt-4.4.1/include -I/opt/mythtv/include -I/usr/include -I/srv/xorg/include -I/srv/lirc/include -I/srv/xorg/include -I../.. -I.. -I. -I../libmyth -I../libavcodec -I../libavutil -I../libmythmpeg2 -Idvbdev -Impeg -Iiptv -I../libmythlivemedia/BasicUsageEnvironment/include -I../libmythlivemedia/groupsock/include -I../libmythlivemedia/liveMedia/include -I../libmythlivemedia/UsageEnvironment/include -I../libmythdb -I../libmythui -I/srv/xorg/include -I. -I. -o moc_siscan.o moc_siscan.cpp ccache g++ -c -pipe -march=pentiumpro -fomit-frame-pointer -O3 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -DSTDC_CONSTANT_MACROS -I/usr/include/freetype2 -D_REENTRANT -DPIC -fPIC -DMMX -Di386 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DUSING_OSS -DUSING_H264TOOLS -DUSING_X11 -DUSING_XV -DUSING_XVMC -DUSING_XVMC_PBUFFER -DUSING_OPENGL -DUSING_XVMC_OPENGL -DUSING_OPENGL_VSYNC -DUSING_OPENGL_VIDEO -DUSING_FRONTEND -DUSING_FFMPEG_THREADS -DUSING_V4L -DUSING_IPTV -DUSING_HDHOMERUN -DUSING_IVTV -DUSING_HDPVR -DUSING_DVB -DUSING_BACKEND -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/opt/qt-4.4.1/mkspecs/linux-g++ -I. -I/opt/qt-4.4.1/include/QtCore -I/opt/qt-4.4.1/include/QtCore -I/opt/qt-4.4.1/include/QtNetwork -I/opt/qt-4.4.1/include/QtNetwork -I/opt/qt-4.4.1/include/QtGui -I/opt/qt-4.4.1/include/QtGui -I/opt/qt-4.4.1/include/QtXml -I/opt/qt-4.4.1/include/QtXml -I/opt/qt-4.4.1/include/QtSql -I/opt/qt-4.4.1/include/QtSql -I/opt/qt-4.4.1/include -I/opt/mythtv/include -I/usr/include -I/srv/xorg/include -I/srv/lirc/include -I/srv/xorg/include -I../.. -I.. -I. -I../libmyth -I../libavcodec -I../libavutil -I../libmythmpeg2 -Idvbdev -Impeg -Iiptv -I../libmythlivemedia/BasicUsageEnvironment/include -I../libmythlivemedia/groupsock/include -I../libmythlivemedia/liveMedia/include -I../libmythlivemedia/UsageEnvironment/include -I../libmythdb -I../libmythui -I/srv/xorg/include -I. -I. -o moc_scanwizardscanner.o moc_scanwizardscanner.cpp ccache g++ -c -pipe -march=pentiumpro -fomit-frame-pointer -O3 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -DSTDC_CONSTANT_MACROS -I/usr/include/freetype2 -D_REENTRANT -DPIC -fPIC -DMMX -Di386 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DUSING_OSS -DUSING_H264TOOLS -DUSING_X11 -DUSING_XV -DUSING_XVMC -DUSING_XVMC_PBUFFER -DUSING_OPENGL -DUSING_XVMC_OPENGL -DUSING_OPENGL_VSYNC -DUSING_OPENGL_VIDEO -DUSING_FRONTEND -DUSING_FFMPEG_THREADS -DUSING_V4L -DUSING_IPTV -DUSING_HDHOMERUN -DUSING_IVTV -DUSING_HDPVR -DUSING_DVB -DUSING_BACKEND -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/opt/qt-4.4.1/mkspecs/linux-g++ -I. -I/opt/qt-4.4.1/include/QtCore -I/opt/qt-4.4.1/include/QtCore -I/opt/qt-4.4.1/include/QtNetwork -I/opt/qt-4.4.1/include/QtNetwork -I/opt/qt-4.4.1/include/QtGui -I/opt/qt-4.4.1/include/QtGui -I/opt/qt-4.4.1/include/QtXml -I/opt/qt-4.4.1/include/QtXml -I/opt/qt-4.4.1/include/QtSql -I/opt/qt-4.4.1/include/QtSql -I/opt/qt-4.4.1/include -I/opt/mythtv/include -I/usr/include -I/srv/xorg/include -I/srv/lirc/include -I/srv/xorg/include -I../.. -I.. -I. -I../libmyth -I../libavcodec -I../libavutil -I../libmythmpeg2 -Idvbdev -Impeg -Iiptv -I../libmythlivemedia/BasicUsageEnvironment/include -I../libmythlivemedia/groupsock/include -I../libmythlivemedia/liveMedia/include -I../libmythlivemedia/UsageEnvironment/include -I../libmythdb -I../libmythui -I/srv/xorg/include -I. -I. -o moc_iptvchannelfetcher.o moc_iptvchannelfetcher.cpp make[2]: * No rule to make target ../libmythlivemedia/libmythlivemedia-0.22.so', needed by libmythtv-0.22.so.0.22.0'. Stop. make[2]: * Waiting for unfinished jobs.... make[2]: Leaving directory `/home/revnew/mythtv/libs/libmythtv' make[1]: * [sub-libmythtv-make_default-ordered] Error 2 make[1]: Leaving directory `/home/revnew/mythtv/libs' make: * [sub-libs-make_default-ordered] Error 2

Change History (11)

comment:1 Changed 11 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newaccepted

comment:2 Changed 11 years ago by danielk

I'm pretty sure the problem is a missing "include (../config.mak)" line in libs.pro. I'm trying to reproduce the error now so I can test this.

comment:3 Changed 11 years ago by danielk

Resolution: fixed
Status: acceptedclosed

(In [18772]) Fixes #5841. include config.mak in libs.pro, CONFIG was not being set causing a fresh checkout to fail to compile.

comment:4 Changed 11 years ago by gigem

(In [18775]) Maybe fix breakage from [18762]. Refs #5841.

comment:5 Changed 11 years ago by danielk

(In [18778]) Refs #5841. Fix breakage from [18775].

comment:6 Changed 11 years ago by Benoit LORAND <benoit.lorand@…>

works fine now, thanks

comment:7 Changed 11 years ago by gigem

Resolution: fixed
Status: closednew

ccache distcc g++ -shared -lfreetype -lz -Wl,-soname,libmythtv-0.22.so.0 -o libmythtv-0.22.so.0.22.0 cc.o vbi.o hamm.o lang.o minilzo.o RTjpegN.o programinfo.o proglist.o RingBuffer?.o avfringbuffer.o ThreadedFileWriter?.o previouslist.o dbcheck.o customedit.o remoteutil.o tv.o recordingtypes.o jobqueue.o filtermanager.o recordingprofile.o remoteencoder.o videosource.o cardutil.o sourceutil.o cc608decoder.o cc708decoder.o cc708window.o sr_dialog.o sr_root.o sr_items.o scheduledrecording.o signalmonitorvalue.o viewschdiff.o livetvchain.o playgroup.o progdetails.o channeleditor.o channelsettings.o previewgenerator.o transporteditor.o importicons.o diseqc.o diseqcsettings.o datadirect.o teletextdecoder.o vbilut.o tspacket.o pespacket.o mpegtables.o atsctables.o dvbtables.o premieretables.o mpegstreamdata.o atscstreamdata.o dvbstreamdata.o scanstreamdata.o mpegdescriptors.o atscdescriptors.o dvbdescriptors.o dishdescriptors.o premieredescriptors.o atsc_huffman.o iso639.o freesat_huffman.o iso6937tables.o h264utils.o frequencies.o frequencytables.o channelutil.o dbchannelinfo.o dtvmultiplex.o dtvconfparser.o dtvconfparserhelpers.o profilegroup.o xbox.o tv_play.o NuppelVideoPlayer?.o DVDRingBuffer.o textsubtitleparser.o xine_demux_sputext.o decoderbase.o nuppeldecoder.o avformatdecoder.o ivtvdecoder.o osd.o osdtypes.o osdsurface.o osdlistbtntype.o osdimagecache.o osdtypeteletext.o udpnotify.o videooutbase.o videoout_null.o videobuffers.o vsync.o jitterometer.o yuv2rgb.o videodisplayprofile.o mythcodecid.o videoout_ivtv.o videoout_xv.o XvMCSurfaceTypes.o osdxvmc.o osdchromakey.o xvmctextures.o util-xvmc.o util-xv.o util-opengl.o openglcontext.o openglvideo.o guidegrid.o infostructs.o progfind.o ttfont.o blend.o channelbase.o dtvchannel.o signalmonitor.o dtvsignalmonitor.o inputinfo.o inputgroupmap.o scanwizard.o scanwizardhelpers.o siscan.o scanwizardscanner.o eithelper.o eitscanner.o eitfixup.o eitcache.o eit.o programdata.o tv_rec.o recorderbase.o DeviceReadBuffer?.o dtvrecorder.o NuppelVideoRecorder?.o fifowriter.o v4lchannel.o analogsignalmonitor.o firewirechannel.o firewirerecorder.o firewiresignalmonitor.o firewiredevice.o avcinfo.o linuxfirewiredevice.o linuxavcinfo.o mpegrecorder.o dvbtypes.o dvbchannel.o dvbsignalmonitor.o dvbcam.o dvbrecorder.o dvbstreamhandler.o dvbci.o moc_proglist.o moc_previouslist.o moc_customedit.o moc_jobqueue.o moc_recordingprofile.o moc_videosource.o moc_sr_dialog.o moc_sr_root.o moc_sr_items.o moc_scheduledrecording.o moc_viewschdiff.o moc_playgroup.o moc_progdetails.o moc_channeleditor.o moc_channelsettings.o moc_previewgenerator.o moc_transporteditor.o moc_importicons.o moc_diseqcsettings.o moc_profilegroup.o moc_xbox.o moc_tv_play.o moc_osd.o moc_osdtypes.o moc_osdlistbtntype.o moc_osdtypeteletext.o moc_udpnotify.o moc_guidegrid.o moc_progfind.o moc_scanwizard.o moc_scanwizardhelpers.o moc_siscan.o moc_scanwizardscanner.o -L/usr/lib -L../libmyth -L../libavutil -L../libavcodec -L../libavformat -L../libmythui -L../libmythupnp -L../libmythmpeg2 -L../libmythdvdnav -L../libmythlivemedia -L../libmythdb -lmyth-0.22 -lmythavutil-0.22 -lmythavcodec-0.22 -lmythavformat-0.22 -lmythui-0.22 -lmythupnp-0.22 -lmythmpeg2-0.22 -lmythdvdnav-0.22 -lmythlivemedia-0.22 -lmythdb-0.22 -lfreetype -lz -lmp3lame -lraw1394 -liec61883 -lavc1394 -lrom1394 -L/usr/X11R6/lib -lXinerama -lXv -lX11 -lXext -lXxf86vm -lXrandr -lXvMCW -lXvMC -ldl -L/opus/mythtv/lib -lGLU -lGL -lpthread -lQtSql -lQtXml -lQtGui -lQtNetwork -lQtCore /usr/bin/ld: cannot find -lmythlivemedia-0.22 collect2: ld returned 1 exit status

This is with [18779] and an empty prefix directory.

comment:8 Changed 11 years ago by danielk

(In [18781]) Refs #5841. Fixes a different problem with mythlivemedia linking.

gigem, if this doesn't fix the problem you are experiencing, I'll need the ./configure line + ./configure & make output to diagnose this.

comment:9 in reply to:  8 Changed 11 years ago by gigem

Replying to danielk:

gigem, if this doesn't fix the problem you are experiencing, I'll need the ./configure line + ./configure & make output to diagnose this.

Fixed. Why does that change look so familiar? :)

comment:10 Changed 11 years ago by danielk

Resolution: fixed
Status: newclosed

heh, it is it is. Two different problems and I had my blinkers on for the second one.

comment:11 Changed 11 years ago by Stuart Auchterlonie

(In [18803]) Refs #5841. Adds a few more libs to make things build

Note: See TracTickets for help on using tickets.