Opened 11 years ago

Closed 9 years ago

#5855 closed enhancement (fixed)

Add H.264 Exporter to Nuvexport

Reported by: David Herman <dave@…> Owned by: beirdo
Priority: minor Milestone: 0.24
Component: Apps - Nuvexport Version: unknown
Severity: low Keywords: h264 nuvexport mythextras
Cc: Ticket locked: no

Description

I have completed the rudimentary steps of adding a basic h.264 encode exporter to nuvexport. It allows the user to change the video bitrate and audio. Audio is encoded using FAAC

Video default should be 1000 and audio should be 128

Attachments (3)

H264.pm (5.0 KB) - added by David Herman <dave@…> 11 years ago.
nuvexport (8.5 KB) - added by David Herman <dave@…> 11 years ago.
Makefile (2.4 KB) - added by David Herman <dave@…> 11 years ago.

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by David Herman <dave@…>

Attachment: H264.pm added

Changed 11 years ago by David Herman <dave@…>

Attachment: nuvexport added

Changed 11 years ago by David Herman <dave@…>

Attachment: Makefile added

comment:1 Changed 11 years ago by xris

fyi, nuvexport can already export to h.264 via the mp4 exporter (the most common format used for h.264 at the time of its writing)

comment:2 Changed 11 years ago by dave@…

Using Mencoder for encoding it seems to produce a better quality video (IMHO). I based the encode string off of h264enc's genenated script. I am considering adding one more configuration to choose between -oac copy and -oac faac. If you find this of value, I will do it.

comment:3 Changed 11 years ago by Dibblah

Status: newassigned

comment:4 Changed 10 years ago by stuartm

Component: perl / nuvexportApps - Nuvexport

comment:5 Changed 10 years ago by beirdo

Owner: changed from xris to beirdo

comment:6 Changed 10 years ago by robertm

Resolution: duplicate
Status: assignedclosed

Dupe of #2976 (Not saying which is better, simply that both accomplish the same goal).

comment:7 Changed 9 years ago by beirdo

Milestone: unknown0.24
Resolution: duplicate
Status: closednew

As the two are slightly different encodings, I'm planning on putting both into nuvexport shortly (with tweaks, of course).

comment:8 Changed 9 years ago by beirdo

Resolution: fixed
Status: newclosed

(In [25430]) Added H.264 exports using mencoder. There is one that uses AAC audio, and one that uses MP3 audio.

This brings up a point in favor of redesigning to choose video codec, audio codec, container format separately in the future.

Closes #5855. Closes #2976.

Note: See TracTickets for help on using tickets.