Opened 11 years ago

Closed 11 years ago

#5871 closed defect (fixed)

Segfault in Upcoming Recordings screen.

Reported by: Marc Alban <marcalban@…> Owned by: stuartm
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If there are no upcoming recordings, then pressing 'menu' or 'info' in the Upcoming Recordings screen results in a segmentation fault.

Attachments (2)

viewscheduled.patch (1.1 KB) - added by Marc Alban <marcalban@…> 11 years ago.
Fix for segfault.
viewscheduled.2.patch (826 bytes) - added by Marc Alban <marcalban@…> 11 years ago.
Fix for segfault. (removed configuration script change that slipped in)

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by Marc Alban <marcalban@…>

Attachment: viewscheduled.patch added

Fix for segfault.

Changed 11 years ago by Marc Alban <marcalban@…>

Attachment: viewscheduled.2.patch added

Fix for segfault. (removed configuration script change that slipped in)

comment:1 Changed 11 years ago by stuartm

Milestone: unknown0.22
Owner: changed from Isaac Richards to stuartm
Status: newaccepted
Version: unknownhead

comment:2 Changed 11 years ago by stuartm

Resolution: fixed
Status: acceptedclosed

(In [18956]) Fix two potential segfaults in mythui ported screens, both caused by failing to check the validity of a button list item pointer before dereferencing. Cleaned up a little too. Closes #5871 and #5873

Note: See TracTickets for help on using tickets.