Opened 11 years ago

Closed 11 years ago

#5873 closed defect (fixed)

Segfault in Schedule Priorities screen

Reported by: Marc Alban <marcalban@…> Owned by: stuartm
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If there are no recording rules, then sorting the recording rules in the Schedule Priorities screen results in a segmentation fault.

Attachments (1)

priority.patch (561 bytes) - added by Marc Alban <marcalban@…> 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by Marc Alban <marcalban@…>

Attachment: priority.patch added

comment:1 Changed 11 years ago by stuartm

Owner: changed from Isaac Richards to stuartm
Status: newaccepted

comment:2 Changed 11 years ago by stuartm

Resolution: fixed
Status: acceptedclosed

(In [18956]) Fix two potential segfaults in mythui ported screens, both caused by failing to check the validity of a button list item pointer before dereferencing. Cleaned up a little too. Closes #5872 and #5873

Note: See TracTickets for help on using tickets.