Opened 12 years ago

Closed 12 years ago

#5879 closed defect (fixed)

mythvideo: svn trunk 18956 don't play DVDs at all "libdvdread: Encrypted DVD support unavailable."

Reported by: ksalmela Owned by: skamithi
Priority: minor Milestone: unknown
Component: DVD Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

When trying to play DVD, Internal player does not use libdvdcss even though it is installed in the computer.

2008-11-03 23:38:50.131 mythfrontend version: trunk [18956] www.mythtv.org 2008-11-03 23:38:50.132 Using runtime prefix = /usr/local 2008-11-03 23:38:51.079 Using localhost value of mythtv 2008-11-03 23:38:51.370 New DB connection, total: 1 2008-11-03 23:38:51.374 Connected to database 'mythconverg' at host: 172.31.255.2 2008-11-03 23:38:51.375 Closing DB connection named 'DBManager0' 2008-11-03 23:38:51.404 DPMS is active. 2008-11-03 23:38:51.405 Primary screen: 0. 2008-11-03 23:38:51.406 Connected to database 'mythconverg' at host: 172.31.255.2 2008-11-03 23:38:51.407 Using screen 0, 1280x720 at 0,0 2008-11-03 23:38:51.449 Current Schema Version: 1223 2008-11-03 23:38:51.449 Enabled verbose msgs: important general 2008-11-03 23:38:51.535 The theme (oldosd) is missing a themeinfo.xml file 2008-11-03 23:38:51.654 The theme (oldosd) is missing a themeinfo.xml file 2008-11-03 23:38:51.785 Primary screen: 0. 2008-11-03 23:38:51.786 Using screen 0, 1280x720 at 0,0 2008-11-03 23:38:51.787 Switching to wide mode (MythCenter?-wide) 2008-11-03 23:38:51.791 Using the Qt painter 2008-11-03 23:38:51.792 lirc init success using configuration file: /root/.mythtv/lircrc 2008-11-03 23:38:51.793 JoystickMenuThread? Error: Joystick disabled - Failed to read /root/.mythtv/joystickmenurc 2008-11-03 23:38:51.989 Loading from: /usr/local/share/mythtv/themes/MythCenter-wide/base.xml 2008-11-03 23:38:52.147 Loading from: /usr/local/share/mythtv/themes/default/base.xml 2008-11-03 23:38:52.152 Connecting to backend server: 172.31.255.2:6543 (try 1 of 5) 2008-11-03 23:38:52.153 Using protocol version 42 2008-11-03 23:38:52.252 Registering Internal as a media playback plugin. 2008-11-03 23:38:52.272 Cannot load language fi for module mythbookmarkmanager 2008-11-03 23:38:52.309 MonitorRegisterExtensions?(0x100, gif,jpg,png) 2008-11-03 23:38:52.316 Cannot load language fi for module mythmovies 2008-11-03 23:38:53.902 Failed to run 'cdrecord --scanbus' error code: 2 QProcess: Destroyed while process is still running. 2008-11-03 23:38:53.939 MonitorRegisterExtensions?(0x40, ogg,mp3,aac,flac) 2008-11-03 23:38:54.046 Failed to find network interface eth0 2008-11-03 23:38:54.047 SIP listening on IP Address :5060 NAT address 2008-11-03 23:38:54.048 SIP: Cannot register; proxy, username or password not set 2008-11-03 23:38:54.048 Cannot load language fi for module mythphone 2008-11-03 23:38:54.722 Loading from: /usr/local/share/mythtv/themes/MythCenter-wide/menu-ui.xml 2008-11-03 23:38:54.856 Found mainmenu.xml for theme 'MythCenter?-wide' 2008-11-03 23:38:54.857 Destroying SipFsm? object 2008-11-03 23:38:54.857 Found a handler - 'MythDVD DVD Media Handler' 2008-11-03 23:38:55.494 Loading from: /usr/local/share/mythtv/themes/MythCenter-wide/menu-ui.xml 2008-11-03 23:39:00.095 New DB connection, total: 2 2008-11-03 23:39:00.095 Connected to database 'mythconverg' at host: 172.31.255.2 2008-11-03 23:39:00.220 TV: Attempting to change from None to WatchingPreRecorded? libdvdnav: Using dvdnav version 0.1.10-xine from http://xine.sf.net libdvdread: Encrypted DVD support unavailable. libdvdnav: DVD Title: NYPD_BLUE_SEASON_2_DISC_2 libdvdnav: DVD Serial Number: 33528C3B libdvdnav: DVD Title (Alternative): NYPD_BLUE_SEASON_2_DISC_2 libdvdnav: Unable to find map file '/root/.dvdnav/NYPD BLUE SEASON 2 DISC 2.map' libdvdread: Invalid main menu IFO (VIDEO_TS.IFO). libdvdnav: vm: faild to read VIDEO_TS.IFO 2008-11-03 23:39:00.326 Failed to open DVD device at /dev/scd0

mythtv:/usr/lib# ls -la libdvdcss* -rw-r--r-- 1 root root 89686 2008-11-03 22:24 libdvdcss.a -rwxr-xr-x 1 root root 812 2008-11-03 22:24 libdvdcss.la lrwxrwxrwx 1 root root 18 2008-11-03 22:24 libdvdcss.so -> libdvdcss.so.2.0.8 lrwxrwxrwx 1 root root 18 2008-11-03 22:24 libdvdcss.so.2 -> libdvdcss.so.2.0.8 -rwxr-xr-x 1 root root 72068 2008-11-03 22:24 libdvdcss.so.2.0.8

Change History (7)

comment:1 Changed 12 years ago by Anduin Withers

Component: mythdvdDVD Playback
Owner: changed from Anduin Withers to skamithi
Status: newassigned

comment:2 Changed 12 years ago by tlawton@…

Glad to hear it's not just me. Same problem here; I've upgraded libraries and recompiled mythtv with no effect. I get the same "libdvdread: Encrypted DVD support unavailable". This box has been able to play dvds under myth with no problems before.

$ ls libdvd* libdvdcss.a libdvdnavmini.so libdvdread.a libdvdcss.la libdvdnavmini.so.4 libdvdread.la libdvdcss.so libdvdnavmini.so.4.1.2 libdvdread.so libdvdcss.so.2 libdvdnav.so libdvdread.so.3 libdvdcss.so.2.1.0 libdvdnav.so.4 libdvdread.so.3.2.1 libdvdnav.a libdvdnav.so.4.1.2

comment:3 Changed 12 years ago by skamithi

Can you help track down which changeset caused this? The problem is between changeset 18442 - 18956. its external to dvdnav code whose last change wn which changeset caused this? The problem is between changeset 18442 - 18956. its external to dvdnav code whose last change was on [17888].

Currently running 18442 on production and I can watch DVDs. Ran 18956 on my dev PC and I can see the issue.

thanks.

comment:4 Changed 12 years ago by ksalmela

I can try binarysearching tonight.

comment:5 Changed 12 years ago by ksalmela

I have narrowed the problem to quite small amount of changes. Maybe someone could guess what could be the problem?

svn 18906 works, svn 18910 does not.. ;-(

comment:6 Changed 12 years ago by Anduin Withers

Ticket locked: set

The problem is known, the ticket system isn't an IM client.

comment:7 Changed 12 years ago by Anduin Withers

Resolution: fixed
Status: assignedclosed

(In [18966]) Closes #5879

Fixes -std=c99 issue.

Note: See TracTickets for help on using tickets.