Opened 14 years ago

Closed 14 years ago

#588 closed defect (fixed)

Focus in list wrong after invoking popup menu

Reported by: Oscar Carlsson Owned by: Isaac Richards
Priority: trivial Milestone: 0.19
Component: mythcontrols Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

When hitting "i" on a menu item not at the top, the selected item jumps to the top when the popups shows. When leaving the popup, and you hit down, you'll end up where you would if the focus would be still in the right place.

Change History (1)

comment:1 Changed 14 years ago by paulh

Resolution: fixed
Status: newclosed

(In [8089]) Fix #588. The problem was caused by mythcontrols updating part of the screen by painting it itself rather than using the usual methods to invalidate part of the screen and have MythThemedDialog? redraw things. It was causing the internal cache image of the screen to become out of sync with reality. When a popup was shown MythThemedDialog? was redrawing the screen using the cached image which was often out of date with what was actually on screen.

Note: See TracTickets for help on using tickets.