Opened 11 years ago

Closed 11 years ago

#5912 closed defect (invalid)

Cannot fast forward, skip forward with latest SVN

Reported by: Paul Lambert <paul at planar.id.au Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: skip
Cc: Ticket locked: no

Description

I upgraded to the latest SVN. Since that point, I've not been able to skip forwards in many of my recorded shows. I have some diagnostics on what is going on, and am quite happy to get more if someone can tell me what sort of information might be useful.

The interesting behaviour here is that I can skip backwards and forwards happily whilst a show is still recording. Pretty much as soon as it finishes recording I lose the ability to skip. It instead shows the position it is skipping to as being the end of the program, but actually either stays where it is, or goes back to the start. It takes a while to do this, so it appears as if it is scanning the whole stream for something, not finding it, then taking me back to the start.

I suspected commercial flagging or transcoding, so I turned both of those off. I still get the same behaviour. Interestingly, it seems to apply to both shows I've recorded recently (since upgrading), and shows from the past - so it seems not to be something that the latest version is doing, rather something with the file or data that is stored when recording finishes.

I tried downgrading back to a version similar to the one I had - somewhere in Sept. I still get the same behaviour, which doesn't make a lot of sense. I also upgraded my debian install at the same time - it could plausibly be some other software that myth is dependent on that is causing the problem. However, after looking through the dependencies for myth I couldn't see anything that would be likely to cause this behaviour.

Change History (3)

comment:1 Changed 11 years ago by Dibblah

Status: newinfoneeded_new

Sounds like your mythconverg.recordedseek table is crashed.

Run the optimize_mythdb.pl script in the contrib\maintainance directory of the Myth source.

comment:2 Changed 11 years ago by Paul Lambert <paul at planar.id.au>

Fantastic - that was great advice. It is indeed crashed when I look in the database, and the optimize_mythdb.pl script has fixed it.

However, anything recorded whilst that table was crashed still won't fast forward. Anything I can do to resolve that? I'm going to try running commercial flagging again to see if that does the trick, but anything else?

Also, any logic to why table crashes happen, or magic in myth that could keep that under control? I guess I should have the optimize script in a cronjob or something? Maybe that should be an automatically set option as part of the base myth install?

comment:3 Changed 11 years ago by Dibblah

Resolution: invalid
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.