Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5915 closed defect (fixed)

mythvideo post download problem

Reported by: wstewart@… Owned by: Anduin Withers
Priority: major Milestone: 0.22
Component: mythvideo Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The first poster that mythvideo downloads is ok. The second and subsequent ones download the wrong poster. I've checked the frontend log and the messages are correct as to which poster it should download. For example: Copying 'http://www.impawards.com/2003/posters/charlies_angels_full_throttle_ver1.jpg' -> '/myth/video/.covers/0305357.jpg' ....

Copying 'http://www.impawards.com/2008/posters/sex_and_the_city.jpg' -> '/myth/video/.covers/1000774.jpg'

The charlie's angel poster downloads correctly. But the second poser becomes the same as the charlie's angle poster rather than the actual one.

Change History (5)

comment:1 Changed 11 years ago by wstewart@…

Problem ocurs in the video manager. Work around is to exit and re-enter the video manager between fetching metadata for videos, then cover art is ok.

Looked at the code, the problem is not obvious to me.

comment:2 Changed 11 years ago by stuartm

Milestone: unknown0.22
Priority: minormajor

The problem is that it's using the same buffer for each image without clearing it in between. So the new images are attached to the end of the old ones.

comment:3 Changed 11 years ago by wstewart@…

Ah, that explains the file size, why it is never the same as the first image.

comment:4 Changed 11 years ago by Anduin Withers

Resolution: fixed
Status: newclosed

(In [19126]) Closes #5915

Quick fix for a bug I introduced when converting to Qt4.

comment:5 Changed 11 years ago by Anduin Withers

(In [19127]) References #5915

Remove prototype for deleted function.

Note: See TracTickets for help on using tickets.