Opened 10 years ago

Closed 10 years ago

#5966 closed defect (invalid)

mythfrontend and mythtv-setup hang upon selection of some menu items in R19237

Reported by: satfan39 Owned by: Isaac Richards
Priority: blocker Milestone: unknown
Component: mythtv Version: unknown
Severity: high Keywords: mythtv-setup
Cc: Ticket locked: no

Description

R19236/7 compiles and installs ok in my environment, but mythtv-setup and mythfrontend hang upon selection of some menu items ( not all of them ).

My environment

Ubuntu 8.10 kernel 2.6.27-7 2 gigabyte ram Core 2 E6850 CPU at 3Ghz s2-liplianin librairies twinhan DVB-S/S2 card AD- SP400 (1041+4046) Trunk 19237

Seems to be a problem with the UI since mythbackend is running OK.

Attachments (7)

mythtv-setup.log (1.6 KB) - added by satfan39 10 years ago.
mythtv-setup log
mythfrontend_log (1.6 KB) - added by satfan39 10 years ago.
progressbar.png (169.0 KB) - added by satfan39 10 years ago.
mythfrontend.log (2.3 KB) - added by satfan39 10 years ago.
mythfrontend2.log (3.1 KB) - added by satfan39 10 years ago.
mythfrontend3.log (1.7 KB) - added by satfan39 10 years ago.
mythbackend.log (3.7 KB) - added by satfan39 10 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 in reply to:  description Changed 10 years ago by anonymous

Same with TRUNK 19245, impossible to use myth-setup to configure mythtv. With an existing database already populated, impossible to use the front end. The frontend is obviously stuck. Options used to configure are --prefix=/usr and --enable-proc-opt

comment:2 Changed 10 years ago by Dibblah

Status: newinfoneeded_new

Can you post frontend logs, please? It sounds like you are using an out-of-date theme.

Changed 10 years ago by satfan39

Attachment: mythtv-setup.log added

mythtv-setup log

comment:3 in reply to:  description Changed 10 years ago by anonymous

I have attached the log ( copy & paste from the terminal window ). ProjectGrayhem? is the theme I am using. The problem is the same with all themes., it just hangs and I have to kill mythtv-setup.

With frontend, I have a similar issue, if I select "watch tv" it does not crash bu I can not watch anything. If I select parameter and "then Aspect", it hangs too and I have to kill the process manually ( same issue than with mythtv-setup -

Changed 10 years ago by satfan39

Attachment: mythfrontend_log added

comment:4 in reply to:  description Changed 10 years ago by satfan39

Also, I noticed somthing strange; the progress bar that appears when launching mythtv-setup or mythfrontend "does not prgress", there is no bar progressing ( see picture ).

Changed 10 years ago by satfan39

Attachment: progressbar.png added

comment:5 Changed 10 years ago by Dibblah

Status: infoneeded_newnew

Which video card are you using? Is it possible that you are running out of video RAM?

comment:6 Changed 10 years ago by Dibblah

Status: newinfoneeded_new

Changed 10 years ago by satfan39

Attachment: mythfrontend.log added

Changed 10 years ago by satfan39

Attachment: mythfrontend2.log added

Changed 10 years ago by satfan39

Attachment: mythfrontend3.log added

comment:7 in reply to:  description Changed 10 years ago by anonymous

(a) Please find enclosed the mythfrontend.log and the mythbackend.log found in /var/log/mythtv

(b) The video card is a Nvidia 8400 GT ( 256 MB ram ). I can watch 720p files with mplayer and mythtv player ( HD suisse for instance ). Release 21 fixes works ok on my system ( R18722 test OK ) . So I dot not think that the videocard is the issue

Changed 10 years ago by satfan39

Attachment: mythbackend.log added

comment:8 Changed 10 years ago by Dibblah

On one of the hangs, can you please capture a backtrace?

http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

Obviously, this is not happening to everyone so there is something in your situation that is unusual.

comment:9 in reply to:  description Changed 10 years ago by anonymous

Did a "fresh" ubuntu 8.10 install ( kernel 2.6.27-10 ) and a fresh compile from svn on a different machine and the problem disapears. So this is definitely a local issue. Will backtrace and post result here.

comment:10 in reply to:  description Changed 10 years ago by satfan39

Reinstalled all the QT4 librairies and the problem dissapeared. This was obviously a local configuration / set up issue with QT4 on my machine. Problem solved after reinstallation of QT4. To be closed.

comment:11 Changed 10 years ago by Dibblah

Resolution: invalid
Status: infoneeded_newclosed

Thanks!

Note: See TracTickets for help on using tickets.