Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5996 closed defect (worksforme)

mythbackend uses 99.9% CPU every 5 Minutes for about 3 Seconds

Reported by: austin Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

mythbuntu hardy weekly repository -> version 0.21.20080304-1 18961 (same issue with mythbuntu hardy standard repository)

I have to admit that my CPU has only 1050 MHz, but nevertheless this is strange because I manage to play back videos with an average CPU-Load of 50%. Every 5 Minutes playback stutters (no matter if recording or dvd, no matter if mythfrontend or xbmc) for a few seconds and according to top mythbackend uses 99.9% (more preceisely it seems to be every 05:15 Minutes, the period is always the same). With no playback the CPU usage is there as well. When I check the console or the messages mythbackend outputs absolutely nothing at these moments.

The same hardware was fine under edgy and 0.20.

Change History (5)

comment:1 Changed 11 years ago by anonymous

btw: "renice"ing and "cpulimit"ing brings no help

comment:2 Changed 11 years ago by Dibblah

Status: newinfoneeded_new

Please post logs of: mythbackend -v most and: mythfrontend -v playback,audio

at the time the issue happens.

Do you have any uPnP devices on your network (media players, PS3, ...)?

comment:3 Changed 11 years ago by Dibblah

Resolution: worksforme
Status: infoneeded_newclosed

comment:4 Changed 11 years ago by anonymous

Hi, just food for thought. I had this issue with a new hard drive by Samsung. Check my solution: http://elkin.de/pivot/entry.php?id=108&w=home_of

comment:5 Changed 11 years ago by Dibblah

Clarification from gbee on IRC:

This is caused by EIT scanning. After collecting EIT data for 5 minutes, the backend will run the scheduler. This is expected behavior. Unfortunately, Myth can interact badly with a system that has high IO latencies - Removing the fsync call from ThreadedFileWriter?.cpp can help work around this issue, in my experience.

Note: See TracTickets for help on using tickets.