Opened 11 years ago

Closed 11 years ago

#6001 closed defect (worksforme)

segfault in sql query, no auto-reconnection

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi. Whilst trying to figure out why this occurs in mythfrontend:

#0  0x00007f7ccc90e3ad in ?? () from /usr/lib/libQtCore.so.4
#1  0x00007f7ccc90a738 in QTextCodec::fromUnicode () from /usr/lib/libQtCore.so.4
#2  0x00007f7cc4d6e5bc in ?? () from /usr/lib/qt4/plugins/sqldrivers/libqsqlmysql.so
#3  0x00007f7ccdef8107 in QSqlQuery::exec () from /usr/lib/libQtSql.so.4
#4  0x00007f7ccfad8105 in MSqlQuery::exec (this=0x7fffda894250) at mythdbcon.cpp:409
#5  0x00007f7cd19200d0 in ProgramInfo::SetBookmark (this=0x23f5e70, pos=0) at programinfo.cpp:1992
#6  0x00007f7cd1cd2914 in NuppelVideoPlayer::SetBookmark (this=0x217cee0) at NuppelVideoPlayer.cpp:4116

It was noticed that if restarting the mysql server that neither mythbackend or mythfrontend would not reconnect.

This may be related as the trace could be for a query on a timed-out connection.

I haven't had much time to look into this more as yet, but probably will tomorrow.

This bug report is FYI and may be bogus yet I never saw this prior to moving to a qt4 enabled mythtv.

Bye

Change History (2)

comment:1 Changed 11 years ago by Dibblah

Status: newinfoneeded_new

I cannot reproduce this on current trunk. The backend appears to reconnect OK to the database when it is restarted.

Which SQL / QT / Myth version is this with?

comment:2 Changed 11 years ago by Dibblah

Resolution: worksforme
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.