Opened 11 years ago

Closed 10 years ago

#6019 closed defect (duplicate)

wakeup scheduled in the past

Reported by: tm3@… Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords: wakeup scheduler
Cc: Ticket locked: no

Description

I had my StartupSecsBeforeRecording? set to 15 minutes (I wanted to allow time for a full fsck on an ext3 file system). My idleWaitForRecordingTime was set for 10 minutes if that matters. I found I was missing recordings because my PC went to sleep and never woke up again. Investigation showed that my PC was being set to wake up at a time that had already past!

I think the simplest bug fix would be to make Scheduler::ShutdownServer?() abort unless the wakeup time was going to be more than idleWaitForRecordingTime * 60 seconds in the future.

Change History (1)

comment:1 Changed 10 years ago by laga

Resolution: duplicate
Status: newclosed

Duplicate of #6066 - you can find a patch there.

Note: See TracTickets for help on using tickets.