Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6040 closed patch (fixed)

Freeview channel number fix

Reported by: David Matthews <dm@…> Owned by: danielk
Priority: minor Milestone: unknown
Component: channelscan Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

I've noticed recently that when I (re)scan the Freeview channels some of the channels that are added have channel numbers using the transport ID instead of the UK channel number.

I've traced the problem to the fact that the broadcaster is sending multiple NITs and SIScan::HandleNIT is clearing the previous channel number information when the second NIT is received. The fix is not to clear the map on each NIT.

I don't know how widespread the problem is or whether it's just on the Central Scotland network but I have seen something on the users list about this problem.

David

Attachments (1)

freeview_chan_nums.patch (422 bytes) - added by David Matthews <dm@…> 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by David Matthews <dm@…>

Attachment: freeview_chan_nums.patch added

comment:1 Changed 11 years ago by anonymous

I have the same issue in the Granda region so the fix is very welcome. Lets hope it gets approved and applied soon. Thanks.

comment:2 Changed 11 years ago by danielk

Resolution: fixed
Status: newclosed

(In [19509]) Fixes #6040. Deal with multiple NITs in Central Scotland. (Don't clear UK global channel number cache on each new NIT)

comment:3 Changed 11 years ago by Stuart Auchterlonie

(In [19539]) Refs #6040. Backports [19509] to 0.21-fixes. Don't clear UK global channel number cache on each new NIT

Note: See TracTickets for help on using tickets.