Opened 11 years ago

Closed 11 years ago

#6050 closed defect (fixed)

Mythweb dies on recording playback

Reported by: eric.bosch@… Owned by: Rob Smith
Priority: minor Milestone: 0.22
Component: mythweb Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Running current SVN 19534, mythweb recordings screen, click on playback .ASX format, I am getting Internal Server Error. The Apache log only shows 2009-01-01 17:12:48 -06:00; saruman; local7.err; apache2[10791]: [error] [client 192.168.1.107] Premature end of script headers: mythweb.pl, referer: http://saruman/mythweb/tv/recorded.

This may be related to a misconfiguration in Apache, but I cannot determine the cause. Is anybody else experiencing this?

Attachments (2)

mythweb.conf (9.0 KB) - added by eric.bosch@… 11 years ago.
mythweb.conf
mythweb-6050-fix_asx_streaming_bindings_requirement.patch (512 bytes) - added by sphery <mtdean@…> 11 years ago.
Patch to fix asx streaming.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by eric.bosch@…

Attachment: mythweb.conf added

mythweb.conf

comment:1 Changed 11 years ago by anonymous

The error seems to be in the "Use MythTV;" statements: the MythTV bindings are not being found by Perl, even though they have been installed (although rather than paying heed to the PREFIX configuration, they insist upon installing in /usr/local/lib (I have prefix set to /usr).

comment:2 Changed 11 years ago by sphery <mtdean@…>

The code in stream.pl that was written to check whether the Perl bindings are available was supposed to fail gracefully if they were not available. However, they don't:

[Thu Jan 15 18:01:12 2009] [error] [client 192.168.0.88] BEGIN failed--compilation aborted at modules/stream/tv.pl line 17.
[Thu Jan 15 18:01:12 2009] [error] [client 192.168.0.88] Compilation failed in require at modules/stream/handler.pl line 17.
[Thu Jan 15 18:01:12 2009] [error] [client 192.168.0.88] Compilation failed in require at /srv/www/htdocs/myth/mythweb.pl line 65.
[Thu Jan 15 18:01:12 2009] [error] [client 192.168.0.88] Premature end of script headers: mythweb.pl

Therefore, currently, the asx streaming code requires that the Perl bindings be installed on the MythWeb host and that they must be functional for the user running the web server. This means that user must have a valid HOME directory inside which the Perl bindings can find a ${HOME}/.mythtv directory (i.e. no /dev/null or otherwise inaccessible/not-writable HOME directory). If either of these conditions is untrue, the asx streaming does not work.

The attached patch changes the eval block to use the "statement" format to trap otherwise-fatal errors (specifically the lines associated with finding the config file). See http://www.perl.com/doc/manual/html/pod/perlfunc/eval.html for more.

Changed 11 years ago by sphery <mtdean@…>

Patch to fix asx streaming.

comment:3 Changed 11 years ago by Rob Smith

Owner: changed from xris to Rob Smith
Status: newaccepted

comment:4 Changed 11 years ago by Rob Smith

Resolution: fixed
Status: acceptedclosed

(In [20110]) Fixes #6050, silly eval syntax...

Note: See TracTickets for help on using tickets.