Opened 11 years ago

Closed 11 years ago

#6051 closed defect (worksforme)

Black screen after selecting channel.

Reported by: ug32axm@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Since upgrading from 0.21 to trunk I'm having trouble when I select a channel in the guide. I get a black screen until the video has buffered, at which point the OSD might finally appear. At other times, I hear the sound come on but I don't see and video or the OSD. I have to reload the guide and close it again for the video to appear. If I click X to tune the channel first and then close the guide, the video appears fine.

The following error appears in the console: TVRec(1): Error: HandleStateChange?(): Null transition from WatchingLiveTV to WatchingLiveTV; TVRec(1): Changing from WatchingLiveTV to None.

I'm using an NVidia FX5200 with their own drivers and XVideo. The tuner card is a Skystar 2 DVB-S card with the gpl driver in v4l-dvb.

Change History (6)

comment:1 Changed 11 years ago by ug32axm@…

I've been testing this and my description was slightly off.

If it's a channel that I've already tuned to (in the guide) and I close the guide, I see a fullscreen frame of the video with osd and then the screen goes black, yet the sound continues. I go back into the guide and tune to a different channel using select, the screen goes black and remains black until the video appears. The OSD then appears, showing LAMC or LAM. I can then change to the channel I originally wanted.

The main problem is the transition between the preview pane and fullscreen video - the video doesn't refresh and the screen stays black. The secondary problem is that the OSD doesn't appear until the video has buffered after I choose a channel from the guide.

Also, this seems only to be a problem with the nvidia drivers and XVideo - fglrx and XVideo works fine on my 9800pro but the video playback is too stuttery to be watchable. CPU is a Pentium D 3.4GHz, 2GB RAM and I'm watching SD DVB-S.

Hope this makes it clearer.

comment:2 Changed 11 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newaccepted

comment:3 Changed 11 years ago by danielk

Status: acceptedinfoneeded

I can't reproduce this. I will need need a "mythbackend -v channel,record,siparser" along with a "mythfrontend -v playback,channel" log and ann exact description of what actions you've taken to reproduce the problem.

comment:4 Changed 11 years ago by danielk

Alse does adding this line to your xorg.conf have any effect?

Option "XvmcUsesTextures?" "true"

(Make sure to remove any <<Option "XvmcUsesTextures?" "false">> lines in the xorg.conf)

comment:5 Changed 11 years ago by anonymous

Feel free to close this. It seems to have fixed itself and I can't seem to break it again.

comment:6 Changed 11 years ago by Nigel

Resolution: worksforme
Status: infoneededclosed
Note: See TracTickets for help on using tickets.