Opened 11 years ago

Closed 11 years ago

#6054 closed defect (duplicate)

Live TV exit dialog problem

Reported by: otto at kolsi dot fi Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When setting "Action on playback exit" is set to "Always prompt (including Live TV)", exiting Live TV does not work. When esc is pressed the playback pauses but the exit dialog that should be displayed either flashes very quickly or is not showed at all.

At the same time, exiting from recorded shows works fine. Also if other options to that setting is used, everything works fine.

Frontend log shows:

2009-01-02 21:31:32.770 Dec: Resyncing position map. posmapStarted = 0 livetv(1) watchingRec(1)
2009-01-02 21:31:32.797 NVP(0): Waiting for prebuffer..  8 UUUUuUULULAAAAAAAAAAAAAAAAAAAAA
2009-01-02 21:31:32.799 AFD: HandleGopStart: gopset not set, syncing positionMap
2009-01-02 21:31:32.799 Dec: Resyncing position map. posmapStarted = 0 livetv(1) watchingRec(1)
2009-01-02 21:31:32.799 AFD: HandleGopStart: Initial key frame distance: 15.
2009-01-02 21:31:32.959 NVP(0): Video is 3.15155 frames ahead of audio,
                        doubling video frame interval to slow down.
2009-01-02 21:31:33.038 NVP(0): Video is 4.1074 frames ahead of audio,
                        doubling video frame interval to slow down.
2009-01-02 21:31:33.118 NVP(0): Video is 4.58055 frames ahead of audio,
                        doubling video frame interval to slow down.
2009-01-02 21:31:33.198 NVP(0): Video is 4.6854 frames ahead of audio,
                        doubling video frame interval to slow down.
2009-01-02 21:31:33.278 NVP(0): Video is 4.5078 frames ahead of audio,
                        doubling video frame interval to slow down.
2009-01-02 21:31:33.358 NVP(0): Video is 4.13085 frames ahead of audio,
                        doubling video frame interval to slow down.
2009-01-02 21:31:33.438 NVP(0): Video is 3.59812 frames ahead of audio,
                        doubling video frame interval to slow down.
'video_output' mean = '43119.47', std. dev. = '10505.17', fps = '23.19'
2009-01-02 21:31:38.704 NVP(0): Changing speed to 0
2009-01-02 21:31:38.704 NVP(0): DoPause() -- begin
2009-01-02 21:31:38.704 rate: 25 speed: 1 skip: 1 = interval 40000
2009-01-02 21:31:38.704 Set video sync frame interval to 40000
2009-01-02 21:31:38.704 NVP(0): DoPause() -- setting paused
2009-01-02 21:31:38.768 VideoOutputXv: UpdatePauseFrame() UuUULUUUUUUUUUUUUUUUAUUUUUUUUUU
2009-01-02 21:31:39.012 TV: SetActive(0,w/o OSD) 0 -> 0 -- begin
2009-01-02 21:31:39.012 TV: SetActive(0,w/o OSD) 0 -> 0 -- end

If esc and/or arrow keys are pressed again while playback is paused (and exit dialog should be visible but is not), log shows following:

2009-01-02 21:33:30.695 OSD, Error: NewDialogBox, dialog containter for 'exitplayoptions' already exists.
2009-01-02 21:33:30.696 TV: SetActive(0,w/o OSD) 0 -> 0 -- begin
2009-01-02 21:33:30.696 TV: SetActive(0,w/o OSD) 0 -> 0 -- end
2009-01-02 21:33:32.169 OSD, Error: NewDialogBox, dialog containter for 'exitplayoptions' already exists.
2009-01-02 21:33:32.169 TV: SetActive(0,w/o OSD) 0 -> 0 -- begin
2009-01-02 21:33:32.170 TV: SetActive(0,w/o OSD) 0 -> 0 -- end

This happens with couple of different playback OSDs.

Attachments (1)

gdb_livetv_exit.txt (23.8 KB) - added by Roo 11 years ago.
Backtrace when livetv paused on exit, trunk 19664

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by Roo

Attachment: gdb_livetv_exit.txt added

Backtrace when livetv paused on exit, trunk 19664

comment:1 Changed 11 years ago by otto at kolsi dot fi

See #6167 for a fix for this one.

comment:2 Changed 11 years ago by Shane Shrybman

Resolution: duplicate
Status: newclosed

Duplicate of #6167. Roo has posted a fix there.

Note: See TracTickets for help on using tickets.