Opened 11 years ago

Closed 11 years ago

#6061 closed defect (duplicate)

Trunk MythMusic doesn't play songs with special characters

Reported by: otto at kolsi dot fi Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythmusic Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After upgrading from -fixes to trunk, songs in MythMusic where there is one or more "special" characters in filename are no longer working.

It seems that e.g. 'รค' character in song filename is now probably in UTF-8 format in DB but then when related song file is tried to open the character conversion is not correct.

MythMusic shows the metadata correctly, even the special character in the filename.

This might be fixed when MythMusic is ported to MythUI etc. but thought to add this ticket IF there is something that needs to be done in schema upgrade so that people's databases do not get wrongly upgraded.

Change History (1)

comment:1 Changed 11 years ago by stuartm

Resolution: โ†’ duplicate
Status: new โ†’ closed

Duplicate of #5822

Note: See TracTickets for help on using tickets.