Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6072 closed defect (fixed)

EIT problem with subtitled field

Reported by: otto at kolsi dot fi Owned by: Janne Grunau
Priority: minor Milestone: 0.22
Component: eit Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

There seems to be problem with EIT parsing in Finnish DVB-T network. Problem can be seen in backend log where there are lots of invalid SQL queries with problem in subtitled field. This field gets following value in DB queries:

''D
2009-01-05 12:47:10.776 MSqlQuery::exec() "UPDATE program SET
title = 'Simpsonit', subtitle = '', description= 'Homer päättelee,
 että naapurin menestyksen salaisuus on rukous ja hän rupeaa
itsekin kokeilemaan sen tehoa. Tapansa mukaan hän käy tässäkin
asiassa ylikierroksilla ja saa aikaan uskomattomia
seurauksia.', category = 'Movie', category_type = 'Movie'TYPE,
starttime = '2009-01-05T13:10:00', endtime =
'2009-01-05T13:40:00', closecaptioned = 'false',
subtitled  = ''D, stereo = 'true', hdtv = 'false',
subtitletypes  = '2', audioprop = '1', videoprop = '0',
partnumber = '0', parttotal = '0', syndicatedepisodenumber = '',
airdate = '0000', originalairdate='', listingsource  = '1',     seriesid = '', programid = '',
previouslyshown = 'false' WHERE chanid = '1006' AND
starttime = '2009-01-05T13:10:00' "

Same problem can be seen in different type of REPLACE query where there is the "REPLACE (fields) values (...)" type of query construction in use.

I've attached one example from the dvbsnoop output where is the same event as is in the query example above.

Attachments (1)

EIT-problem-event.txt (4.2 KB) - added by otto at kolsi dot fi 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by otto at kolsi dot fi

Attachment: EIT-problem-event.txt added

comment:1 Changed 11 years ago by Janne Grunau

Milestone: unknown0.22
Owner: changed from Stuart Auchterlonie to Janne Grunau
Status: newaccepted

the problem seems to be that named placeholders in qt sql queries can't be prefixes of other placeholders. i.e. the placholder :SUBTITLED is replaced with the value os :SUBTITLE and the 'D' remains.

I assume this is a qt4 regression.

comment:2 Changed 11 years ago by Janne Grunau

Resolution: fixed
Status: acceptedclosed

(In [19580]) Avoid common prefixes in named placeholders.

Apperently some Qt versions do replacements on the shortest match. Fixes #6072

comment:3 Changed 11 years ago by Janne Grunau

(In [19585]) Avoid another common prefix problem in named placeholders. Refs #6072

Note: See TracTickets for help on using tickets.