Opened 11 years ago

Closed 10 years ago

#6089 closed defect (fixed)

Mythgallery crashes frontend (repeatable)

Reported by: ian@… Owned by: stuartm
Priority: minor Milestone: 0.22
Component: Plugin - MythGallery Version: head
Severity: high Keywords: frontend, crash, gallery
Cc: Ticket locked: no

Description

I have a diskless front end running mythgallery 0.21.0+fixes18722-0ubuntu1 with no initial images. I copied a folder of jpgs into the pictures dir. Go into the Gallery plugin, folder is represented, but no images. Click on the menu button, select "Random" - boof. No more front end.

Nothing in the mythtv logs, but dmesg is catching this (two separate instances)

[ 477.169868] mythfrontend.re[5023] trap divide error ip:7f5c6a20e7a5 sp:7fff7fe2fa80 error:0 in libmythgallery.so[7f5c6a1d1000+61000]

[ 124.928909] mythfrontend.re[5025] trap divide error ip:7f2c05c8e7a5 sp:7fff1bcf2740 error:0 in libmythgallery.so[7f2c05c51000+61000]

Attached please find the dmesg, mount, and dpkg outputs. If there's anything else I can provide to assist, please let me know.

Thanks!

Attachments (1)

attach.tgz (29.2 KB) - added by ian@… 11 years ago.
dmesg output

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by ian@…

Attachment: attach.tgz added

dmesg output

comment:1 Changed 10 years ago by Dibblah

Status: newinfoneeded_new

Please follow: http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

To get a backtrace.

comment:2 Changed 10 years ago by stuartm

Milestone: unknown0.22
Status: infoneeded_newnew

comment:3 Changed 10 years ago by stuartm

Owner: changed from Isaac Richards to stuartm
Status: newaccepted

comment:4 Changed 10 years ago by paulh

Component: mythgalleryPlugin - MythGallery
Resolution: fixed
Status: acceptedclosed
Version: 0.21-fixeshead

Can't reproduce this in trunk, probably fixed by [19993]

Note: See TracTickets for help on using tickets.