Opened 11 years ago

Closed 11 years ago

#6103 closed enhancement (fixed)

bigclock patch to use selected Time Format vs hardcoded 24-hour format

Reported by: J-e-f-f-A (junk_inbox@… Owned by: paulh
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: low Keywords: bigclock
Cc: Ticket locked: no

Description

The attached patch changes the LCD bigclock to display in the same format as the "Localization" "Time format".

Attachments (3)

bigclock.patch (3.5 KB) - added by J-e-f-f-A (junk_inbox@… 11 years ago.
bigclock patch to use selected Time format vs hardcoded 24-hour clock
bigclock_v2.patch (3.5 KB) - added by J-e-f-f-A (junk_inbox@… 11 years ago.
v2 - Moved AM/PM up to line 2 for compatibility with Imon LCD.
bigclock_v3.patch (3.7 KB) - added by J-e-f-f-A (junk_inbox@… 11 years ago.
v3 - fixes issues found by paulh ;-)

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by J-e-f-f-A (junk_inbox@…

Attachment: bigclock.patch added

bigclock patch to use selected Time format vs hardcoded 24-hour clock

comment:1 Changed 11 years ago by RyeBrye@…

The numbers work fine for my Imon LCD screen - I don't see the AM/PM text string but that's of little concern since I can do that conversion in my head much faster than I can do the 0-23 -> 1-12 conversion...

Please apply this patch. It will be good to see some momentum on LCD-related patches.

Changed 11 years ago by J-e-f-f-A (junk_inbox@…

Attachment: bigclock_v2.patch added

v2 - Moved AM/PM up to line 2 for compatibility with Imon LCD.

comment:2 Changed 11 years ago by J-e-f-f-A (junk_inbox@…

Added some pics of the patch in use on my web site: http://jartz.gotdns.com:8008/files/lcd/bigclock_patch.html

comment:3 Changed 11 years ago by paulh

Owner: changed from Isaac Richards to paulh
Status: newassigned

J-e-f-f-A there is a problem with this patch it causes mythlcdserver to fail to start up for me because of an ASSERT. The problem is the timeformat hasn't been set the first time dobigclock() is called from Init().

Changed 11 years ago by J-e-f-f-A (junk_inbox@…

Attachment: bigclock_v3.patch added

v3 - fixes issues found by paulh ;-)

comment:4 Changed 11 years ago by J-e-f-f-A (junk_inbox@…

New patch uploaded (bigclock_v3.patch)
Removes un-necessary init call to dobigclock in LCDProcClient::init
Removes un-necessary init processing in LCDProcCLient::dobigclock as there is nothing to initialize within this function. All necessary initialization is already done within LCDProcClient::init

comment:5 Changed 11 years ago by paulh

Resolution: fixed
Status: assignedclosed

(In [19952]) Use the user selected time format for the big clock LCD screen rather than always using 24 hour format. Adds an am/pm indicator and flashes a dot instead of the colon.

This will use the myth system wide time format by default but if you want to use a different format for the LCD you can add a 'LCDTimeFormat' setting in the DB and it will use that.

Patch by J-e-f-f-A. Closes #6103.

Note: See TracTickets for help on using tickets.