Opened 11 years ago

Closed 9 years ago

#6106 closed defect (invalid)

LCDProc: Scrolling menus on small LCD displays lack first 3 characters

Reported by: avdongen@… Owned by: paulh
Priority: minor Milestone: unknown
Component: MythTV - Mythlcdserver Version: head
Severity: low Keywords: LCDproc menu scroll
Cc: Ticket locked: no

Description

Context: When menus are shown on a LCDProc display, they can scroll to the left when the text is too long for the width of the display. And the menu texts can be preceded by " ", "> " or "X " based on selected and checked status. In smaller LCD displays (<= 12 chars) the spaces are to be trimmed here. Observed: Menu ">Manage Recordin" changes to "> anage Recordin" when it starts scrolling. The extra spaces are not trimmed here.

Attachments (2)

scrolldiff.out (7.1 KB) - added by avdongen@… 11 years ago.
Patch to consequently add (or don't add) spaces on menus
scrolldiff.2.out (4.7 KB) - added by avdongen@… 11 years ago.
re-submit patch, now for this fix only.

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by avdongen@…

Attachment: scrolldiff.out added

Patch to consequently add (or don't add) spaces on menus

comment:1 Changed 11 years ago by avdongen@…

The issue is a bit different than I thought at first sight. The root cause was that:

  1. global (??!!) var lcdStartCol was only initialized in the constructor of LCDProcClient, before the display width is set to the correct value;
  2. De different locations where the menu text is changed used different conditions to select the prefix of the menu text.

Both are fixed in the attached scrolldiff.out

comment:2 Changed 11 years ago by Dibblah

Status: newinfoneeded_new

Please can you separate your patches? This one appears to be including the priority fix as well.

Changed 11 years ago by avdongen@…

Attachment: scrolldiff.2.out added

re-submit patch, now for this fix only.

comment:3 Changed 10 years ago by Dibblah

Status: infoneeded_newnew

comment:4 Changed 10 years ago by paulh

Component: mythtvMythTV - Mythlcdserver
Milestone: unknown0.22
Owner: changed from Isaac Richards to paulh
Status: newassigned
Version: 0.21-fixeshead

comment:5 Changed 10 years ago by paulh

Milestone: 0.220.23

Not got time to look at this before 0.22.

comment:6 Changed 10 years ago by paulh

Milestone: 0.23unknown

Can you please update this patch for current trunk.

comment:7 Changed 9 years ago by paulh

Resolution: invalid
Status: assignedclosed

No reply in 6 weeks. Please reopen when you have an updated patch.

Note: See TracTickets for help on using tickets.