Opened 11 years ago

Closed 11 years ago

#6131 closed defect (invalid)

MythTV backend gives up too early on HD Homerun tuner when network is not available at startup

Reported by: q.steenhuis@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.21-fixes
Severity: high Keywords: HD Homerun, network, tuner
Cc: Ticket locked: no

Description

Running HD Homerun with a stock MythBuntu? system with the ubuntu-desktop package (and gnome-network-manager) installed, it is quite possible that the network will start up after mythbackend. This is possible in many other configurations as well, and it's also possible that the same will happen if a machine temporarily loses network connection, or depends on a wireless configuration. However, mythbackend gives up after trying the HD HomeRun? tuner once. It should try again at least when trying to record a scheduled show and again if trying to watch live TV, in case initial tuner unavailability was fixed.

The alternative is that all packagers will ensure that mythtv-backend service depends on the network service, but there's no good reason for mythbackend to give up after just one try.

Change History (1)

comment:1 Changed 11 years ago by danielk

Resolution: invalid
Status: newclosed

Not a bug in mythtv. mythbackend depends on the network being set up for most of it's functions. MythBuntu? should not attempt to start mythbackend before the network has been set up and ntpd has initialized the clock.

Note: See TracTickets for help on using tickets.