Opened 11 years ago

Closed 11 years ago

#6139 closed patch (fixed)

MythUIButtonList fixes

Reported by: Isaac Richards Owned by: stuartm
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The attached patch fixes a few issues with MythUIButtonList scrolling/etc. It also simplifies the code a bit.

I did not change the current behavior of pageup/down not wrapping if wrap items/sel was set. Wasn't sure if it's by design or not, but it does "feel" right to not wrap when using it.

Attachments (1)

buttonlistfix.diff (14.0 KB) - added by Isaac Richards 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by Isaac Richards

Attachment: buttonlistfix.diff added

comment:1 Changed 11 years ago by Isaac Richards

Resolution: fixed
Status: newclosed

(In [19719]) MythUIButtonList fixes:

  • No longer gets confused when scrolling rapidly + wrapping items
  • Consolidate scrolling code
  • Remove old optimization code that kept pointers to various items - no longer necessary since in Qt4, QList is essentially a deque instead of a linked list.
  • When keeping the center item selected, and there are fewer than the total # of possible items on screen, don't repeat them to fill up available items if set to item wrap. Makes Terra work/feel better.

Fixes #6139

Note: See TracTickets for help on using tickets.