Opened 12 years ago

Closed 12 years ago

#6157 closed defect (fixed)

If no database, mythbackend from init loops

Reported by: Nigel Owned by: Nigel
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If there is a bad mysql.txt somewhere, mythbackend can loop like this:

...
2009-01-22 12:33:33.783 Testing network connectivity to 
2009-01-22 12:33:33.798 Cannot find (ping) database host  on the network
2009-01-22 12:33:33.799 Cannot find (ping) database host  on the network

Cannot find (ping) database host  on the network

Would you like to configure the database connection now? [yes]  
[console is not interactive, using default 'yes']
Database host name:  
[console is not interactive, using default '']
Should I test connectivity to this host using the ping command? [yes]  
[console is not interactive, using default 'yes']
Database non-default port: [0]  
[console is not interactive, using default '0']
Database name:  
[console is not interactive, using default '']
Database user name:  
[console is not interactive, using default '']
Database password:  
[console is not interactive, using default '']
Unique identifier for this machine (if empty, the local host name will be used):  
[console is not interactive, using default '']
Would you like to use Wake-On-LAN to retry database connections? [no]  
[console is not interactive, using default 'no']
2009-01-22 12:33:33.812 Testing network connectivity to 
2009-01-22 12:33:33.828 Cannot find (ping) database host  on the network
2009-01-22 12:33:33.829 Cannot find (ping) database host  on the network

Cannot find (ping) database host  on the network

Would you like to configure the database connection now? [yes]  
[console is not interactive, using default 'yes']
...

Should check for interactivity in FindDatabase?()

Change History (3)

comment:1 Changed 12 years ago by greg

It looks like this is also related to UPNP. It happens for me sporadically when the preview generation happens. the spawned mythbackend fails to get the data from the upnp server on the main process and instead of falling back to it's config files it just cycles.

# 2009-01-22 08:23:12.122 Using runtime prefix = /usr/local # 2009-01-22 08:23:12.124 Empty LocalHostName?. # 2009-01-22 08:23:12.125 Using localhost value of woop # 2009-01-22 08:23:14.754 HTTPRequest::ParseRequest? - Unable to read entire payload (read 0 of 321 bytes # 2009-01-22 08:23:14.774 HTTPRequest::ProcessSOAPPayload : "urn:schemas-mythtv-org:service:MythTv:1#GetConnectionInfo" : # 2009-01-22 08:23:14.774 Error parsing request at line: 1 column: 1 : unexpected end of file # 2009-01-22 08:23:14.776 HttpWorkerThread::ProcessWork? - ParseRequest? Failed. # 2009-01-22 08:23:14.778 HTTPRequest::SendResponse?( None ) :501 Not Implemented -> 192.168.0.10: # 2009-01-22 08:23:14.780 HttpWorkerThread::ProcessWork? socket(41) - Error returned from SendResponse?... Closing connection # 2009-01-22 08:23:16.427 HTTPRequest::ParseRequest? - Unable to read entire payload (read 0 of 321 bytes # 2009-01-22 08:23:16.551 HTTPRequest::ProcessSOAPPayload : "urn:schemas-mythtv-org:service:MythTv:1#GetConnectionInfo" : # 2009-01-22 08:23:16.553 Error parsing request at line: 1 column: 1 : unexpected end of file # 2009-01-22 08:23:16.555 HttpWorkerThread::ProcessWork? - ParseRequest? Failed. # 2009-01-22 08:23:16.557 HTTPRequest::SendResponse?( None ) :501 Not Implemented -> 192.168.0.10: # 2009-01-22 08:23:16.559 HttpWorkerThread::ProcessWork? socket(40) - Error returned from SendResponse?... Closing connection # 2009-01-22 08:23:16.590 MythXMLClient::GetConnectionInfo? Failed - (1) unexpected end of file # 2009-01-22 08:23:16.592 Testing network connectivity to 192.168.0.10 # 2009-01-22 08:23:16.654 New DB connection, total: 1 # 2009-01-22 08:23:16.657 Unable to connect to database! # 2009-01-22 08:23:16.658 Driver error was [1/1130]: # QMYSQL: Unable to connect # Database error was: # Host 'woop.phaze.org' is not allowed to connect to this MySQL server # # 2009-01-22 08:23:16.677 Cannot login to database? # # Cannot login to database? # # Would you like to configure the database connection now? [yes] # [console is not interactive, using default 'yes']

comment:2 Changed 12 years ago by Nigel

Owner: changed from Isaac Richards to Nigel
Status: newassigned

This could be fixed in MythContextPrivate::FindDatabase?() by adding another special test (isInteractive) and loop exit, but I don't think there is any harm in just making the interactive database config default to no?

comment:3 Changed 12 years ago by Nigel

Resolution: fixed
Status: assignedclosed

(In [20215]) Prevent pointless looping in non-interactive setups. Fixes #6157 (I hope).

Note: See TracTickets for help on using tickets.