Opened 11 years ago

Closed 11 years ago

#6163 closed defect (invalid)

HDHomerun is constantly tuned and streaming to backend

Reported by: mattpiermarini@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.21-fixes
Severity: medium Keywords: hdhomerun streaming
Cc: Ticket locked: no

Description

This is a followup for ticket #6135. I did not have permission to re-open that ticket. I stated in ticket #6135 that both HDHR tuners are constantly tuned and streaming to mythbackend. No frontends are even running. That ticket was closed (invalid) and mentioned this is probably EIT data. My HDHR has IET disabled. I use zap2it IET.

To verify tuned:

[root@media libhdhomerun]# ./hdhomerun_config FFFFFFFF get /tuner0/target
udp://192.168.0.53:60338
[root@media libhdhomerun]# ./hdhomerun_config FFFFFFFF get /tuner1/target
udp://192.168.0.53:54667

Verify EIT disabled.

[root@media libhdhomerun]# ./hdhomerun_config FFFFFFFF get /lineup/location

disabled

Here is a sample of the tcpdump when there no frontends running. HDHR-10108CD6 is the HDHR and media (192.168.0.53) is the mythbackend server.

13:49:05.797662 IP HDHR-10108CD6.avt-profile-1 > media.54667: UDP, length 1316
13:49:05.808245 IP HDHR-10108CD6.avt-profile-1 > media.54667: UDP, length 1316
13:49:05.808306 IP HDHR-10108CD6.rfe > media.60338: UDP, length 1316
13:49:05.836802 IP HDHR-10108CD6.avt-profile-1 > media.54667: UDP, length 1316
13:49:05.836865 IP HDHR-10108CD6.rfe > media.60338: UDP, length 1316
13:49:05.850597 IP HDHR-10108CD6.avt-profile-1 > media.54667: UDP, length 1316
13:49:05.850658 IP HDHR-10108CD6.rfe > media.60338: UDP, length 1316
13:49:05.870899 IP HDHR-10108CD6.rfe > media.60338: UDP, length 1316
13:49:05.870958 IP HDHR-10108CD6.avt-profile-1 > media.54667: UDP, length 1316
13:49:05.890717 IP HDHR-10108CD6.avt-profile-1 > media.54667: UDP, length 1316
13:49:05.890861 IP HDHR-10108CD6.rfe > media.60338: UDP, length 1316
13:49:05.904669 IP HDHR-10108CD6.rfe > media.60338: UDP, length 1316
13:49:05.904730 IP HDHR-10108CD6.avt-profile-1 > media.54667: UDP, length 1316
13:49:05.924684 IP HDHR-10108CD6.avt-profile-1 > media.54667: UDP, length 1316
13:49:05.924759 IP HDHR-10108CD6.rfe > media.60338: UDP, length 1316
13:49:05.975516 IP HDHR-10108CD6.rfe > media.60338: UDP, length 1316
13:49:05.975576 IP HDHR-10108CD6.avt-profile-1 > media.54667: UDP, length 1316
13:49:05.988408 IP HDHR-10108CD6.rfe > media.60338: UDP, length 1316
13:49:05.988473 IP HDHR-10108CD6.avt-profile-1 > media.54667: UDP, length 1316
13:49:06.023530 IP HDHR-10108CD6.rfe > media.60338: UDP, length 1316
13:49:06.023592 IP HDHR-10108CD6.avt-profile-1 > media.54667: UDP, length 1316
13:49:06.038845 IP HDHR-10108CD6.avt-profile-1 > media.54667: UDP, length 1316
13:49:06.038907 IP HDHR-10108CD6.rfe > media.60338: UDP, length 1316

Change History (5)

comment:1 Changed 11 years ago by Janne Grunau

Owner: changed from Isaac Richards to danielk
Status: newassigned

I would guess the mythtv configuration is more important

comment:2 Changed 11 years ago by mattpiermarini@…

I'm not sure this helps, but given the previous comment about EIT data, I turned on EIT debugging. This is the log (messages) that occur as soon as the HDHR starts streaming packets and never stops:

2009-01-25 22:44:05.158 EITScanner (1): StartActiveScan called with 8 multiplexes
2009-01-25 22:44:05.405 EITScanner (1): Now looking for EIT data on multiplex of channel 26.3
2009-01-25 22:44:05.406 EITCache: Pruning all entries that ended before UTC 2009-01-24T22:49:19
2009-01-25 22:44:05.407 EITCache: Deleting old cache entries from the database
2009-01-25 22:44:06.046 Adding Source #1 ATSC chan 26-1
2009-01-25 22:44:06.046 Adding Source #4 ATSC chan 26-4
2009-01-25 22:44:06.047 Adding Source #3 ATSC chan 26-3
2009-01-25 22:44:06.047 Adding Source #2 ATSC chan 26-2
2009-01-25 22:44:06.214 EITScanner (1): Started passive scan.
2009-01-25 22:44:06.631 EITHelper: Added 1 events -- complete(0) incomplete(4) unmatched(4)
2009-01-25 22:44:10.173 AutoExpire: CalcParams(): Max required Free Space: 1.0 GB w/freq: 15 min
2009-01-25 22:44:14.669 EITHelper: Added 3 events -- complete(2) incomplete(4) unmatched(4)
2009-01-25 22:44:15.080 EITHelper: Added 1 events -- complete(1) incomplete(4) unmatched(4)
2009-01-25 22:44:15.492 EITHelper: Added 1 events -- complete(0) incomplete(4) unmatched(4)
2009-01-25 22:44:20.178 EITScanner (2): StartActiveScan called with 8 multiplexes
2009-01-25 22:44:20.248 EITScanner (2): Now looking for EIT data on multiplex of channel 7.2
2009-01-25 22:44:20.249 EITCache: Pruning all entries that ended before UTC 2009-01-24T22:49:30
2009-01-25 22:44:20.249 EITCache: Deleting old cache entries from the database
2009-01-25 22:44:20.559 Adding Source #3 ATSC chan 7-3
2009-01-25 22:44:20.559 Adding Source #1 ATSC chan 7-1
2009-01-25 22:44:20.560 Adding Source #2 ATSC chan 7-2
2009-01-25 22:44:20.605 EITScanner (2): Started passive scan.
2009-01-25 22:44:21.070 EITHelper: Added 3 events -- complete(3) incomplete(3) unmatched(3)
2009-01-25 22:44:21.486 EITHelper: Added 3 events -- complete(2) incomplete(3) unmatched(3)
2009-01-25 22:44:21.892 EITHelper: Added 1 events -- complete(1) incomplete(3) unmatched(3)
2009-01-25 22:44:22.301 EITHelper: Added 1 events -- complete(0) incomplete(3) unmatched(3)
2009-01-25 22:44:23.139 EITHelper: Added 5 events -- complete(4) incomplete(3) unmatched(3)
2009-01-25 22:44:23.550 EITHelper: Added 2 events -- complete(2) incomplete(3) unmatched(3)
2009-01-25 22:44:23.957 EITHelper: Added 1 events -- complete(1) incomplete(3) unmatched(3)
2009-01-25 22:44:24.363 EITHelper: Added 1 events -- complete(0) incomplete(3) unmatched(3)
2009-01-25 22:44:29.989 EITHelper: Added 4 events -- complete(3) incomplete(3) unmatched(3)
2009-01-25 22:44:30.412 EITHelper: Added 3 events -- complete(2) incomplete(3) unmatched(3)
2009-01-25 22:44:30.818 EITHelper: Added 1 events -- complete(1) incomplete(3) unmatched(3)
2009-01-25 22:44:31.224 EITHelper: Added 1 events -- complete(0) incomplete(3) unmatched(3)
2009-01-25 22:45:15.531 EITScanner (1): Added 6 EIT Events
2009-01-25 22:45:15.534 Reschedule requested for id -1.
2009-01-25 22:45:15.866 Scheduled 94 items in 0.3 = 0.01 match + 0.31 place
2009-01-25 22:45:31.262 EITScanner (2): Added 26 EIT Events

comment:3 Changed 11 years ago by Dibblah

Which means that EIT scanning is enabled in Myth. EIT is enabled and disabled primarily by channel - If you can, go into mythtv-setup, channel setup and disable EIT there for each channel.

Otherwise, execute the following SQL query against the database: update mythconverg.channel set useonairguide=0;

comment:4 Changed 11 years ago by Dibblah

An easier option is to disable it on the video source - Untick the "Perform EIT scan" tickbox on the video source setup page in mythtv-setup

comment:5 Changed 11 years ago by Janne Grunau

Resolution: invalid
Status: assignedclosed

caused by EIT scanning

Note: See TracTickets for help on using tickets.